summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2018-05-20 17:42:36 +0000
committerFelix Yan2018-05-20 17:42:36 +0000
commit4f112bfcc4af4972da0ca876688b304f3bf4b940 (patch)
treea88f93d3e785f69d46b062a901a94128bb4b682a
parente56e323c03aa90abb51036aaf81b1e08903f98bc (diff)
downloadaur-4f112bfcc4af4972da0ca876688b304f3bf4b940.tar.gz
upgpkg: 0.4-1
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33fbc73038f6..3a677cd2c8f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,36 @@
pkgbase=python-editdistance
pkgname=('python-editdistance' 'python2-editdistance')
-pkgver=0.3.1
-_commit=3ea84a7dd3258c76aa3be851ef3d50e59c886846
+pkgver=0.4
pkgrel=1
pkgdesc="Fast implementation of the edit distance(Levenshtein distance)"
arch=('x86_64')
license=('MIT')
url="https://github.com/aflc/editdistance"
-makedepends=('python-setuptools' 'python2-setuptools' 'git')
-source=("git+https://github.com/aflc/editdistance.git#commit=$_commit"
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/aflc/editdistance/archive/v$pkgver.tar.gz"
LICENSE)
-sha512sums=('SKIP'
+sha512sums=('8487d5aa2c516e4ee0aea2a63670ebd512cd443eb48c1ca99a7fe334518c0731c33ddb97ce158f5afe665a739d69c86bc247c49ad2489839cc60566385aeaf5d'
'590232c1e7fa5aaaaa77573c4ea23533522177ca0ac07a0ce7f00e446d47467df2e19936ecb5e057fddc664d1daca39e2217cb5f6e3192ef5edf49b1f73e0f10')
prepare() {
- cp -a editdistance{,-py2}
+ cp -a editdistance-$pkgver{,-py2}
export LC_CTYPE=en_US.UTF-8
}
build() {
- cd "$srcdir"/editdistance
+ cd "$srcdir"/editdistance-$pkgver
python setup.py build
- cd "$srcdir"/editdistance-py2
+ cd "$srcdir"/editdistance-$pkgver-py2
python2 setup.py build
}
package_python-editdistance() {
depends=('python')
- cd editdistance
+ cd editdistance-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -40,7 +39,7 @@ package_python-editdistance() {
package_python2-editdistance() {
depends=('python2')
- cd editdistance-py2
+ cd editdistance-$pkgver-py2
python2 setup.py install --root="$pkgdir" --optimize=1
install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}