summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-04-21 09:42:24 +0200
committerHans-Nikolai Viessmann2021-04-21 09:42:24 +0200
commit45b8f26621f45a6f9f345ae3112a6b8e09638e72 (patch)
treec62c1e2a55f308c32ce5c8799ac0014cb71d5a41
downloadaur-45b8f26621f45a6f9f345ae3112a6b8e09638e72.tar.gz
initial commit; 2.0.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28b283c1d739
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-eduvpn-client
+ pkgdesc = Linux client and Python client API for eduVPN
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/eduvpn/python-eduvpn-client
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-requests-oauthlib
+ depends = python-pynacl
+ depends = mypy
+ depends = dbus-python
+ depends = python-gobject
+ depends = hicolor-icon-theme
+ source = https://github.com/eduvpn/python-eduvpn-client/archive/refs/tags/2.0.0.tar.gz
+ sha256sums = 4cef709f90eb574de6488cebc7a5b116634dc68bdd4e1145918b711c84a1433e
+
+pkgname = python-eduvpn-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e535bfced29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
+pkgname=python-eduvpn-client
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Linux client and Python client API for eduVPN"
+arch=('any')
+url="https://github.com/eduvpn/python-eduvpn-client"
+license=('Apache')
+depends=('python-requests-oauthlib' 'python-pynacl' 'mypy' 'dbus-python' 'python-gobject' 'hicolor-icon-theme')
+makedepends=('python-setuptools')
+source=("https://github.com/eduvpn/python-eduvpn-client/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('4cef709f90eb574de6488cebc7a5b116634dc68bdd4e1145918b711c84a1433e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}