summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2022-03-02 17:53:57 +0100
committerHans-Nikolai Viessmann2022-03-02 17:53:57 +0100
commit89c834e6407a9dab20ad14c3db0de60cf95c9f40 (patch)
tree014e4016af29f92e591ce23c3b5b6f48068afd82
parentc06b8dd72e2b35b2cb3470ff677df8f78ea02714 (diff)
downloadaur-89c834e6407a9dab20ad14c3db0de60cf95c9f40.tar.gz
switch to using PEP517 build process
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0e0906b16b8..215404e279fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = python-eduvpn-client
pkgdesc = Linux client and Python client API for eduVPN
pkgver = 2.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/eduvpn/python-eduvpn-client
arch = any
license = Apache
- makedepends = python-setuptools
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
depends = python-requests-oauthlib
depends = python-pynacl
depends = mypy
diff --git a/PKGBUILD b/PKGBUILD
index b24f4b375f3b..dd75f5df1966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
pkgname=python-eduvpn-client
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Linux client and Python client API for eduVPN"
arch=('any')
url="https://github.com/eduvpn/python-eduvpn-client"
license=('Apache')
depends=('python-requests-oauthlib' 'python-pynacl' 'mypy' 'dbus-python' 'python-gobject' 'hicolor-icon-theme' 'python-wheel')
-makedepends=('python-setuptools' 'python-pip')
+makedepends=('python-build' 'python-installer')
source=("https://github.com/eduvpn/python-eduvpn-client/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('d359bb93ba65a617a99bee4c34c803cdd6c66df63348a03544c4e5f50d48b2b4')
build() {
cd "${pkgname}-${pkgver}"
- /usr/bin/python setup.py build
+ /usr/bin/python -m build --wheel --no-isolation --skip-dependency-check
}
package() {
cd "${pkgname}-${pkgver}"
- PYTHONHASHSEED=0 /usr/bin/python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ PYTHONHASHSEED=0 /usr/bin/python -m installer --destdir="$pkgdir" dist/*.whl
}