summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiernov2022-06-10 18:59:20 +0200
committerpiernov2022-06-10 18:59:20 +0200
commit021830d7a5fe56352a57f83a34063c9063fc2956 (patch)
treebb5c8105ef963418f4d2239d582426c1565737de
downloadaur-021830d7a5fe56352a57f83a34063c9063fc2956.tar.gz
python-efficientnet-pytorch 1.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01e29d0b9858
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-efficientnet-pytorch
+ pkgdesc = PyTorch implementation of EfficientNet
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/lukemelas/EfficientNet-PyTorch
+ arch = any
+ license = APACHE
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools-scm
+ depends = python-pytorch
+ source = python-efficientnet-pytorch-1.0.tar.gz::https://github.com/lukemelas/EfficientNet-PyTorch/archive/refs/tags/1.0.tar.gz
+ sha256sums = 01789984000ff1de132094cadf85fb2973f474aab61715cc8acab6918d59bd80
+
+pkgname = python-efficientnet-pytorch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6f241f3c07a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: piernov <piernov@piernov.org>
+
+pkgname=python-efficientnet-pytorch
+pkgver=1.0
+pkgrel=1
+pkgdesc="PyTorch implementation of EfficientNet"
+arch=('any')
+url="https://github.com/lukemelas/EfficientNet-PyTorch"
+license=('APACHE')
+depends=('python-pytorch')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/lukemelas/EfficientNet-PyTorch/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('01789984000ff1de132094cadf85fb2973f474aab61715cc8acab6918d59bd80')
+
+build() {
+ cd "$srcdir"/EfficientNet-PyTorch-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/EfficientNet-PyTorch-$pkgver
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}