summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorahtn2019-06-10 16:41:51 +1000
committerahtn2019-06-10 16:41:51 +1000
commit6a16d3efa81e01082c5eb130edca61d0d95385a8 (patch)
tree79b50af3ef5822c4ffe2bba75ac1337e015d9ebd
downloadaur-python-efm8boot.tar.gz
init commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f76a2441848
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-efm8boot
+ pkgdesc = library for writing to efm8 factory bootloader
+ pkgver = 0.0.8
+ pkgrel = 1
+ url = https://github.com/ahtn/python-efm8boot
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-easyhid
+ depends = python-intelhex
+ depends = python-crcmod
+ provides = python-efm8boot
+ conflicts = python-efm8boot
+ source = python-efm8boot-0.0.8.tar.gz::https://github.com/ahtn/python-efm8boot/archive/0.0.8.tar.gz
+ sha512sums = b12bde82331a2a4f0e23e62b473eb68c4968e6fa6f3081ea944fd59ef523c69e6c7cde210277e84cb00d45068a6146bbdc88cda38930e0dde9283acbf54eab88
+
+pkgname = python-efm8boot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39e5a4f708c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: jem <jem ΑΤ seethis DΟΤ link>
+pkgname=python-efm8boot
+pkgver=0.0.8
+pkgrel=1
+epoch=
+pkgdesc="library for writing to efm8 factory bootloader"
+arch=('any')
+url="https://github.com/ahtn/python-efm8boot"
+license=('MIT')
+groups=()
+depends=('python-easyhid' 'python-intelhex' 'python-crcmod')
+makedepends=('python' 'python-setuptools')
+checkdepends=()
+optdepends=()
+provides=('python-efm8boot')
+conflicts=('python-efm8boot')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+)
+sha512sums=(
+ 'b12bde82331a2a4f0e23e62b473eb68c4968e6fa6f3081ea944fd59ef523c69e6c7cde210277e84cb00d45068a6146bbdc88cda38930e0dde9283acbf54eab88'
+)
+noextract=()
+validpgpkeys=()
+
+_srcdir="${pkgname}-${pkgver}"
+
+build() {
+ cd $_srcdir
+ python setup.py build
+}
+
+package() {
+ cd $_srcdir
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm 644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}