summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-01-12 03:37:03 +0800
committerUniversebenzene2021-01-12 03:37:03 +0800
commitfd8f6a948f78e92a414d1c6a751904d63f190e07 (patch)
tree21e50dd93cd75c0a40ccc18b18ba2a22cf5af1bd
parentdadf12787118fcfd33219a7d2804ec80d2d767b3 (diff)
downloadaur-fd8f6a948f78e92a414d1c6a751904d63f190e07.tar.gz
Update from upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20f4384249f7..465492025cf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = python-einsteinpy-git
pkgdesc = Python package for General Relativity
- pkgver = 0.1.0.r647.g77ce582
+ pkgver = 0.1.0.r652.g86d0b7d
pkgrel = 1
url = https://einsteinpy.org
arch = i686
arch = x86_64
license = MIT
- checkdepends = python-pytest
+ checkdepends = python-pytest-doctestplus
checkdepends = python-matplotlib
checkdepends = python-sympy
checkdepends = python-plotly
diff --git a/PKGBUILD b/PKGBUILD
index 734d1619206f..eca7e6da3e95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgbase=python-einsteinpy-git
_gitname=einsteinpy
pkgname=("python-${_gitname}-git" "python-${_gitname}-doc-git")
-pkgver=0.1.0.r647.g77ce582
+pkgver=0.1.0.r652.g86d0b7d
pkgrel=1
pkgdesc="Python package for General Relativity"
arch=('i686' 'x86_64')
url="https://einsteinpy.org"
license=('MIT')
makedepends=('git' 'python-setuptools' 'python-scipy' 'python-nbsphinx' 'pandoc' 'graphviz')
-checkdepends=('python-pytest' 'python-matplotlib' 'python-sympy' 'python-plotly' 'python-astropy' 'python-numba' 'python-einsteinpy_geodesics')
+checkdepends=('python-pytest-doctestplus' 'python-matplotlib' 'python-sympy' 'python-plotly' 'python-astropy' 'python-numba' 'python-einsteinpy_geodesics')
source=("git+https://github.com/einsteinpy/einsteinpy")
md5sums=('SKIP')
@@ -22,6 +22,13 @@ pkgver() {
)
}
+#prepare() {
+# cd ${srcdir}/${_gitname}
+#
+# sed '/julia/s/False/True/g' -i tests/test_plotting/test_geodesic/test_interactive.py \
+# -i tests/test_plotting/test_geodesic/test_static.py -i tests/test_geodesic/test_geodesic.py
+#}
+
build() {
cd ${srcdir}/${_gitname}
python setup.py build
@@ -33,7 +40,7 @@ build() {
check() {
cd ${srcdir}/${_gitname}
- PYTHONPATH="build/lib" pytest
+ PYTHONPATH="build/lib" pytest tests
}
package_python-einsteinpy-git() {