summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-09-08 20:45:36 -0500
committerCarlos Aznarán Laos2022-09-08 20:45:36 -0500
commitf35109292f89bd3a01c3d0ddab68ef23978737f9 (patch)
tree5626d1e919022c95c69649bff89bb4c6220e8782
downloadaur-f35109292f89bd3a01c3d0ddab68ef23978737f9.tar.gz
Bump version to 0.9.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD30
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d27db1209be8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-einsumt
+ pkgdesc = Multithreaded version of numpy.einsum function
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/mrkwjc/einsumt
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-numpy
+ source = einsumt-0.9.2.tar.gz::https://github.com/mrkwjc/einsumt/archive/0.9.2.tar.gz
+ sha512sums = 868087bae6660fb7127857dba6991df883c9ec07bc667e121ae9dffb5ff8ed6d51ac00f2f41edc48e08e922880aff55076216b4b1a13d83de81ef694a673bdef
+
+pkgname = python-einsumt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ecbc0b971dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=einsumt
+pkgname=python-${_base}
+pkgdesc="Multithreaded version of numpy.einsum function"
+pkgver=0.9.2
+pkgrel=1
+arch=(any)
+url="https://github.com/mrkwjc/${_base}"
+license=(MIT)
+depends=(python-numpy)
+makedepends=(python-setuptools)
+checkdepends=(python-pytest)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('868087bae6660fb7127857dba6991df883c9ec07bc667e121ae9dffb5ff8ed6d51ac00f2f41edc48e08e922880aff55076216b4b1a13d83de81ef694a673bdef')
+
+build() {
+ cd ${_base}-${pkgver}
+ python setup.py build
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python test_einsumt.py
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}