summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2019-07-08 23:59:05 -0400
committerDanManN2019-07-08 23:59:05 -0400
commit14880216802155c7f91db5dc492a672163207866 (patch)
tree76410580b4b7aee3f3a3ab2ef312377e6a7d1d87
downloadaur-14880216802155c7f91db5dc492a672163207866.tar.gz
first
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10befe46ed81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-elevate
+ pkgdesc = Python library for requesting root privileges
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/barneygale/elevate
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-elevate
+ conflicts = python-elevate
+ source = https://files.pythonhosted.org/packages/81/32/29ba61063ac124632754e26c65e71217f48ce682fbf8762ee9a0bb0d32de/elevate-0.1.3.tar.gz
+ source = https://github.com/barneygale/elevate/raw/master/COPYING.txt
+ sha256sums = 53ad19fa1de301fb1de3f8768fb3a5894215716fd96a475690c4d0ff3b1de209
+ sha256sums = SKIP
+
+pkgname = python-elevate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eda753e1ccaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: DanManN <dnahimov@gmail.com>
+# Python package author: Barney Gale <barney.gale@gmail.com>
+
+_pkgname=elevate
+_author=barneygale
+pkgname=python-$_pkgname
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Python library for requesting root privileges"
+arch=('any')
+url="https://github.com/$_author/$_pkgname"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+provides=("python-$_pkgname")
+conflicts=("python-$_pkgname")
+source=("https://files.pythonhosted.org/packages/81/32/29ba61063ac124632754e26c65e71217f48ce682fbf8762ee9a0bb0d32de/elevate-0.1.3.tar.gz"
+ "https://github.com/barneygale/elevate/raw/master/COPYING.txt"
+ )
+sha256sums=('53ad19fa1de301fb1de3f8768fb3a5894215716fd96a475690c4d0ff3b1de209'
+ 'SKIP'
+ )
+
+# build() {
+# cd "$srcdir/$_pkgname-$pkgver"
+# python setup.py build
+# }
+
+package(){
+ install -Dm644 COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}