summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-10-01 15:46:03 +0800
committerUniversebenzene2019-10-01 15:46:03 +0800
commitb51fbb8a4ec12cea61ecfd984941fe42f0c77daa (patch)
tree22f40fcd566e079047fdb389b553afb5de674a7e
downloadaur-b51fbb8a4ec12cea61ecfd984941fe42f0c77daa.tar.gz
Initial import 3.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD33
-rw-r--r--fix_MPI_python_highlight.patch11
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cbac8c0ccd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-emcee-doc
+ pkgdesc = Documentation for Python emcee
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://emcee.readthedocs.io
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python-emcee=3.0.0
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
+ source = https://github.com/dfm/emcee/archive/v3.0.0.tar.gz
+ source = fix_MPI_python_highlight.patch
+ md5sums = a6f411904868f8d4356a6b3215294f8b
+ md5sums = 04636e60d509170af5e537588de57a0c
+
+pkgname = python-emcee-doc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d6e3b36c63a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53cf8d20f089
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=emcee
+pkgname=python-${_pyname}-doc
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Documentation for Python emcee"
+arch=('i686' 'x86_64')
+url="http://emcee.readthedocs.io"
+license=('MIT')
+makedepends=("python-${_pyname}=${pkgver}" 'python-sphinx' 'python-sphinx_rtd_theme')
+source=("https://github.com/dfm/emcee/archive/v${pkgver}.tar.gz"
+ 'fix_MPI_python_highlight.patch')
+md5sums=('a6f411904868f8d4356a6b3215294f8b'
+ '04636e60d509170af5e537588de57a0c')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ patch -Np1 -i "${srcdir}/fix_MPI_python_highlight.patch"
+}
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+}
diff --git a/fix_MPI_python_highlight.patch b/fix_MPI_python_highlight.patch
new file mode 100644
index 000000000000..c772427c5b0c
--- /dev/null
+++ b/fix_MPI_python_highlight.patch
@@ -0,0 +1,11 @@
+--- a/docs/tutorials/parallel.rst 2019-09-30 22:37:34.000000000 +0800
++++ b/docs/tutorials/parallel.rst 2019-10-01 15:24:02.945541070 +0800
+@@ -195,7 +195,7 @@
+ print(end - start)
+ """)
+
+- mpi_time = !mpiexec -n {ncpu} python script.py
++ #mpi_time = !mpiexec -n {ncpu} python script.py
+ mpi_time = float(mpi_time[0])
+ print("MPI took {0:.1f} seconds".format(mpi_time))
+ print("{0:.1f} times faster than serial".format(serial_time / mpi_time))