summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-06-13 14:55:42 +0800
committerUniversebenzene2023-06-13 14:55:42 +0800
commit1738ea3ec5b7549a9a29c7be46c0906c3498a4b2 (patch)
tree3b8b84ed7cf2ff877b30a25972bf77ae510e1f9f
parent33492314419b52c0aa15c7861b11173a4ebaa09c (diff)
downloadaur-1738ea3ec5b7549a9a29c7be46c0906c3498a4b2.tar.gz
Update from upstream
-rw-r--r--.SRCINFO12
-rw-r--r--[-rwxr-xr-x]PKGBUILD54
2 files changed, 35 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95fd5c0590b4..73dbf5871989 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
pkgbase = python-emcee-git
pkgdesc = The Python ensemble sampling toolkit for affine-invariant MCMC
- pkgver = 3.1.2.dev3+g9e407ee
+ pkgver = 3.1.4.dev6+gc3164ce
pkgrel = 1
url = https://pypi.org/project/emcee
arch = any
license = MIT
- checkdepends = python-h5py
checkdepends = python-pytest
+ checkdepends = python-h5py
checkdepends = python-scipy
makedepends = git
+ makedepends = python-setuptools-scm
makedepends = python-build
makedepends = python-installer
- makedepends = python-setuptools-scm
makedepends = python-wheel
depends = python-numpy
- optdepends = python-h5py
+ optdepends = python-tqdm: For progress bars
+ optdepends = python-h5py: For HDF5 backend
optdepends = python-scipy
+ optdepends = python-emcee-doc: Documentations for emcee
+ provides = python-emcee
+ conflicts = python-emcee
source = python-emcee::git+https://github.com/dfm/emcee.git
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c4cd9496bfca..e34b09204668 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
# Contributor: Dan Foreman-Mackey
@@ -5,7 +6,7 @@
pkgname='python-emcee-git'
_basename="${pkgname%-git}"
_distname="${_basename#python-}"
-pkgver=3.1.2.dev3+g9e407ee
+pkgver=3.1.4.dev6+gc3164ce
pkgrel=1
pkgdesc='The Python ensemble sampling toolkit for affine-invariant MCMC'
arch=('any')
@@ -13,43 +14,42 @@ url="https://pypi.org/project/${_distname}"
_repourl="https://github.com/dfm/${_distname}"
license=('MIT')
depends=('python-numpy')
-makedepends=(
- 'git'
- 'python-build'
- 'python-installer'
- 'python-setuptools-scm'
- 'python-wheel'
-)
-checkdepends=(
- 'python-h5py'
- 'python-pytest'
- 'python-scipy'
-)
-optdepends=(
- 'python-h5py'
- 'python-scipy'
-)
+makedepends=('git'
+ 'python-setuptools-scm'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel')
+checkdepends=('python-pytest'
+ 'python-h5py'
+ 'python-scipy')
+optdepends=('python-tqdm: For progress bars'
+ 'python-h5py: For HDF5 backend'
+ 'python-scipy'
+ 'python-emcee-doc: Documentations for emcee')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=("${_basename}::git+${_repourl}.git")
b2sums=('SKIP')
pkgver() {
- cd "${_basename}"
- printf "%s" "$(git describe --long --tags | sed 's/\([^-]*\)-g/dev\1+g/;s/-/./g;s/^v//')"
+ cd "${_basename}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*\)-g/dev\1+g/;s/-/./g;s/^v//')"
}
build() {
- cd "${_basename}"
- python -m build --wheel --no-isolation
+ cd "${_basename}"
+ python -m build --wheel --no-isolation
}
check() {
- #python -c 'import emcee; emcee.test()'
- cd "${_basename}"
- pytest -v || warning 'Tests failed'
+ #python -c 'import emcee; emcee.test()'
+ cd "${_basename}"
+ pytest -v || warning 'Tests failed' # -vv --color=yes
}
package() {
- cd "${_basename}"
- python -m installer --destdir="${pkgdir}" dist/*.whl
- install -Dm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "${_basename}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}