summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdoardo Rosa2019-05-19 22:43:29 +0200
committerEdoardo Rosa2019-05-19 22:43:29 +0200
commitdfac438c41ca79e8ab56b66ac29ed34aef364743 (patch)
treec5b386b2da32192d8612140eb8e9b12910c3622d
downloadaur-dfac438c41ca79e8ab56b66ac29ed34aef364743.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1481092288e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-eml-parser
+ pkgdesc = Parse EML files and return various information found in the e-mail
+ pkgver = 1.11.2
+ pkgrel = 1
+ url = https://pypi.org/project/eml-parser
+ arch = x86_64
+ license = GPLv3
+ depends = python
+ depends = python-chardet
+ depends = python-dateutil
+ source = python-eml-parser.tar.gz::https://github.com/GOVCERT-LU/eml_parser/archive/v1.11.2.tar.gz
+ sha512sums = f1f2cd6f72f2aa1957c024fafc7ac5b10b60570eebfc89de5650e19149f601a9f710602b672dead2174f9d5398984da7765eb14a52ffcf0882528c3b03524f43
+
+pkgname = python-eml-parser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a19d3d74559
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: edoz90 <edoardo [dot] rosa90 [at] gmail [dot] com>
+
+_pkgname=eml_parser
+pkgname=python-eml-parser
+pkgver=1.11.2
+pkgrel=1
+pkgdesc='Parse EML files and return various information found in the e-mail'
+url='https://pypi.org/project/eml-parser'
+arch=('x86_64')
+license=('GPLv3')
+depends=('python' 'python-chardet' 'python-dateutil')
+source=(${pkgname}.tar.gz::"https://github.com/GOVCERT-LU/eml_parser/archive/v${pkgver}.tar.gz")
+sha512sums=('f1f2cd6f72f2aa1957c024fafc7ac5b10b60570eebfc89de5650e19149f601a9f710602b672dead2174f9d5398984da7765eb14a52ffcf0882528c3b03524f43')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py install --root="${pkgdir}" -O1 --skip-build
+}