summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSameer2018-12-12 21:07:42 -0600
committerSameer2018-12-12 21:08:08 -0600
commit18f7e75e1df2d4b8f7100996d54fce16abfa9af4 (patch)
treed60ab918f8e8ac2fd69ec5bc6d432556ceeee854
downloadaur-18f7e75e1df2d4b8f7100996d54fce16abfa9af4.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--LICENSE96
-rw-r--r--PKGBUILD102
-rw-r--r--PKGBUILD_EXTRAS0
4 files changed, 223 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..348a67df41fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-enaml
+ pkgdesc = Declarative DSL for building rich user interfaces in Python
+ pkgver = 0.10.2
+ pkgrel = 00
+ url = https://github.com/nucleic/enaml
+ arch = x86_64
+ license = custom:
+ makedepends = python-pip
+ makedepends = python-wheel
+ depends = python
+ depends = python-qtpy
+ depends = python-future
+ depends = python-ply
+ depends = python-kiwisolver
+ depends = python-setuptools
+ depends = python-atom
+ source = PKGBUILD_EXTRAS
+ source = https://files.pythonhosted.org/packages/30/fe/b95b1a93d6296c1c16a618d857c0a892a80d7e5bc7cbb506acad9818d6b6/enaml-0.10.2.tar.gz
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 4bd4157f88e9b5a28385dea73ef20e74
+ md5sums = 7b198a7b1296c1659830cbb4f1c65f2e
+
+pkgname = python-enaml
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c87cce88e662
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,96 @@
+==========================
+ The Enaml licensing terms
+==========================
+Enaml is licensed under the terms of the Modified BSD License (also known as
+New or Revised BSD), as follows:
+
+Copyright (c) 2013, Nucleic Development Team
+Copyright (c) 2013, Enthought, Inc.
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+Redistributions of source code must retain the above copyright notice, this
+list of conditions and the following disclaimer.
+
+Redistributions in binary form must reproduce the above copyright notice, this
+list of conditions and the following disclaimer in the documentation and/or
+other materials provided with the distribution.
+
+Neither the name of the Nucleic Development Team nor the names of its
+contributors may be used to endorse or promote products derived from this
+software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+About Enaml
+-----------
+Chris Colbert began the Enaml project under the umbrella of Enthought, Inc.
+in August 2011. The project was forked into the Nucleic project in March
+2013. Chris is still the project lead.
+
+The Nucleic Development Team is the set of all contributors to the Nucleic
+project and its subprojects.
+
+The core team that coordinates development on GitHub can be found here:
+http://github.com/nucleic. The current team consists of:
+
+* Chris Colbert
+* Matthieu Dartiailh
+
+Previous contributors include:
+
+* Ioannis Tziakos
+* Robert Kern
+* Corran Webster
+* David Wyde
+* Brett Patterson
+* Tim Diller
+* John Wiggins
+* Didrik Pinte
+* Deepankar Sharma
+* Kelsey Jordahl
+* Naveen Michaud-Agrawal
+* Steven Silvester
+* Mark Dickinson
+* Simon Jagoe
+* Chris Farrow
+* Puneeth Chaganti
+* Matthew Scott
+* Jack Minardi
+* Warren Weckesser
+* Christoph Gohlke
+
+Our Copyright Policy
+--------------------
+Nucleic uses a shared copyright model. Each contributor maintains copyright
+over their contributions to Nucleic. But, it is important to note that these
+contributions are typically only changes to the repositories. Thus, the Nucleic
+source code, in its entirety is not the copyright of any single person or
+institution. Instead, it is the collective copyright of the entire Nucleic
+Development Team. If individual contributors want to maintain a record of what
+changes/contributions they have specific copyright on, they should indicate
+their copyright in the commit message of the change, when they commit the
+change to one of the Nucleic repositories.
+
+With this in mind, the following banner should be used in any source code file
+to indicate the copyright and license terms:
+
+#------------------------------------------------------------------------------
+# Copyright (c) 2013-2018, Nucleic Development Team.
+#
+# Distributed under the terms of the Modified BSD License.
+#
+# The full license is in the file COPYING.txt, distributed with this software.
+#------------------------------------------------------------------------------
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e996d4c1ad8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,102 @@
+# Maintainer: Unknown Packager
+
+export PIP_CONFIG_FILE=/dev/null
+export PIP_DISABLE_PIP_VERSION_CHECK=true
+
+pkgname=python-enaml
+epoch=
+pkgver=0.10.2
+pkgrel=00
+pkgdesc='Declarative DSL for building rich user interfaces in Python'
+arch=(x86_64)
+url=https://github.com/nucleic/enaml
+license=(custom:)
+depends=(python python-qtpy python-future python-ply python-kiwisolver python-setuptools python-atom)
+depends+=()
+makedepends=(python-pip python-wheel)
+checkdepends=()
+provides=()
+conflicts=(${provides%=*}) # No quotes, to avoid an empty entry.
+source=(PKGBUILD_EXTRAS)
+md5sums=(SKIP)
+source+=(https://files.pythonhosted.org/packages/30/fe/b95b1a93d6296c1c16a618d857c0a892a80d7e5bc7cbb506acad9818d6b6/enaml-0.10.2.tar.gz)
+md5sums+=(4bd4157f88e9b5a28385dea73ef20e74)
+source+=(LICENSE)
+md5sums+=(7b198a7b1296c1659830cbb4f1c65f2e)
+_first_source() {
+ echo " ${source_i686[@]} ${source_x86_64[@]} ${source[@]}" |
+ tr ' ' '\n' | grep -Pv '^(PKGBUILD_EXTRAS)?$' | head -1
+}
+
+if [[ $(_first_source) =~ ^git+ ]]; then
+ provides+=("${pkgname%-git}")
+ conflicts+=("${pkgname%-git}")
+fi
+
+_is_wheel() {
+ [[ $(_first_source) =~ \.whl$ ]]
+}
+
+_dist_name() {
+ basename "$(_first_source)" |
+ sed 's/\(\.tar\.gz\|\.tgz\|\.tar\.bz2\|\.zip\|\.git\)$//'
+}
+
+if [[ $(_first_source) =~ ^git+ ]]; then
+ _pkgver() {
+ ( set -o pipefail
+ cd "$srcdir/$(_dist_name)"
+ git describe --long --tags 2>/dev/null |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+ }
+
+ pkgver() { _pkgver; }
+fi
+
+_build() {
+ if _is_wheel; then return; fi
+ cd "$srcdir/$(_dist_name)"
+ # See Arch Wiki/PKGBUILD/license.
+ # Get the first filename that matches.
+ local test_name
+ if [[ ${license[0]} =~ ^(BSD|MIT|ZLIB|Python)$ ]]; then
+ for test_name in LICENSE LICENSE.txt license.txt COPYING COPYING.md COPYING.rst COPYING.txt COPYRIGHT; do
+ if cp "$srcdir/$(_dist_name)/$test_name" "$srcdir/LICENSE" 2>/dev/null; then
+ break
+ fi
+ done
+ fi
+ # Build the wheel (which we allow to fail) only after fetching the license.
+ /usr/bin/pip wheel -v --no-deps --wheel-dir="$srcdir" \
+ --global-option=--no-user-cfg \
+ --global-option=build --global-option=-j"$(nproc)" . ||
+ true
+}
+
+build() { _build; }
+
+_check() {
+ # Define check(), possibly using _check as a helper, to run the tests.
+ # You may need to call `python setup.py build_ext -i` first.
+ if _is_wheel; then return; fi
+ cd "$srcdir/$(_dist_name)"
+ /usr/bin/python setup.py -q test
+}
+
+_package() {
+ cd "$srcdir"
+ # pypa/pip#3063: pip always checks for a globally installed version.
+ /usr/bin/pip --quiet install --root="$pkgdir" \
+ --no-deps --ignore-installed --no-warn-script-location \
+ "$(ls ./*.whl 2>/dev/null || echo ./"$(_dist_name)")"
+ if [[ -f LICENSE ]]; then
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ fi
+}
+
+package() { _package; }
+
+. "$(dirname "$BASH_SOURCE")/PKGBUILD_EXTRAS"
diff --git a/PKGBUILD_EXTRAS b/PKGBUILD_EXTRAS
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/PKGBUILD_EXTRAS