summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-28 07:32:42 +1200
committercaltlgin2020-08-28 07:32:42 +1200
commite78be7684724a2471379bc54fcc4de0cec5a01cf (patch)
tree3c094d3583393da4a5d05f68da791a9f3384f40e
downloadaur-e78be7684724a2471379bc54fcc4de0cec5a01cf.tar.gz
Add to AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45275a208025
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-envinfopy
+ pkgdesc = Python Library to get execution environment information
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/thombashi/envinfopy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = envinfopy
+ source = https://files.pythonhosted.org/packages/source/e/envinfopy/envinfopy-0.0.3.tar.gz
+ sha256sums = cbee4e6ea91b48b9cfafc5817aa97a44f1d61065a9aa37e5e909838da232ec20
+
+pkgname = python-envinfopy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6844be15c4cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname=envinfopy
+pkgname=python-${_pkgname}
+pkgver=0.0.3
+pkgrel=1
+pkgdesc='Python Library to get execution environment information'
+arch=('any')
+url='https://github.com/thombashi/envinfopy'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+provides=("${_pkgname}")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('cbee4e6ea91b48b9cfafc5817aa97a44f1d61065a9aa37e5e909838da232ec20')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+}
+
+# vim: ts=2 sw=2 et: