summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Chapuis2018-03-22 14:42:25 +0100
committerPierre Chapuis2018-03-22 14:42:25 +0100
commite65cbac337025328146a5059bf334f892c36a7fd (patch)
treee774cd1c3e89a4c5200b05c1336ef8cbaab140ed
downloadaur-python-envparse.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acea4b7aa64b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-envparse
+ pkgdesc = Simple environment variable parsing
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/envparse
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/2f/8d/bee8a59732c169a455627ff1557d0db180f7c352b0274480267ad3e46875/envparse-0.2.0.tar.gz
+ sha256sums = 4f3b9a27bb55d27f124eb4adf006fec05e4588891c9a054a183a112645056eb7
+
+pkgname = python-envparse
+
+pkgname = python2-envparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce9f88ca8339
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Pierre Chapuis <catwell@archlinux.us>
+
+pkgname=("python-envparse" "python2-envparse")
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Simple environment variable parsing"
+arch=("any")
+url="https://pypi.python.org/pypi/envparse"
+license=("BSD")
+makedepends=("python-setuptools" "python2-setuptools")
+source=("https://pypi.python.org/packages/2f/8d/bee8a59732c169a455627ff1557d0db180f7c352b0274480267ad3e46875/envparse-$pkgver.tar.gz")
+sha256sums=("4f3b9a27bb55d27f124eb4adf006fec05e4588891c9a054a183a112645056eb7")
+
+build() {
+ cd "$srcdir"
+ rm -rf python{2,3}-build
+ for builddir in python{2,3}-build; do
+ cp -r "envparse-$pkgver" "$builddir"
+ pushd "$builddir"
+ "${builddir%-build}" setup.py build
+ popd
+ done
+}
+
+package_python-envparse() {
+ cd "$srcdir/python3-build"
+ python3 setup.py install --root="$pkgdir" -O1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-envparse() {
+ cd "$srcdir/python2-build"
+ python2 setup.py install --root="$pkgdir" -O1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}