summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Radović2024-05-18 16:57:09 +0200
committerAndrej Radović2024-05-18 16:57:09 +0200
commite8a8a7b28eeca65a09cde003e5e16a18b19601b1 (patch)
treecee290458ed187c9ebb1fc032fdc03824ecb2038
downloadaur-e8a8a7b28eeca65a09cde003e5e16a18b19601b1.tar.gz
Added error helper
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b0df614a8f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-error-helper
+ pkgdesc = minimalistic python module which helps you print colorful messages for CLI tools
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/30350n/error_helper
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-hatchling
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/e/error_helper/error_helper-1.1.tar.gz
+ sha256sums = 7753b3e7509373b7f525ced9b98da3bed09e3c3839c93405b061f00e5a7e67ab
+
+pkgname = python-error-helper
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5e3ecf19a8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andrej Radović <r.andrej@gmail.com>
+pkgname=python-error-helper
+_name=${pkgname#python-}
+pkgver=1.1
+pkgrel=1
+pkgdesc="minimalistic python module which helps you print colorful messages for CLI tools"
+url="https://github.com/30350n/error_helper"
+depends=(
+ 'python'
+)
+makedepends=(python-build python-installer python-wheel python-hatchling)
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
+sha256sums=('7753b3e7509373b7f525ced9b98da3bed09e3c3839c93405b061f00e5a7e67ab')
+
+build() {
+ cd "$srcdir/${_name//-/_}-$pkgver/${_name//-/_}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/${_name//-/_}-$pkgver/${_name//-/_}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}