summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-20 17:16:09 -0800
committerclintval2018-01-20 17:16:09 -0800
commit88f6c44cd4546a58d8344997323cc7f903e4c554 (patch)
treea622beb3fc62d96f5e563ef3f3af662a60c758fd
downloadaur-88f6c44cd4546a58d8344997323cc7f903e4c554.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD60
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebc907322083
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = python-ete
+ pkgdesc = Python toolkit for building, comparing, annotating, manipulating and visualising phylogenetic trees
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/ete
+ arch = any
+ license = GPL3
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-ete-3.1.1.tar.gz::https://pypi.python.org/packages/21/17/3c49b7fafe10ed63bb7904ebf9764b98db726aa5fd482fb006818854bc04/ete3-3.1.1.tar.gz
+ sha256sums = 870a3d4b496a36fbda4b13c7c6b9dfa7638384539ae93551ec7acb377fb9c385
+
+pkgname = python-ete
+ depends = python
+ depends = python-six
+ optdepends = python-lxml: Nexml and Phyloxml support
+ optdepends = python-numpy: ArrayTable and ClusterTree class support
+ optdepends = python-pyqt4: tree visualization and image rendering
+ optdepends = python-pyqt5: tree visualization and image rendering
+
+pkgname = python2-ete
+ depends = python2
+ depends = python2-six
+ optdepends = python2-lxml: Nexml and Phyloxml support
+ optdepends = python2-numpy: ArrayTable and ClusterTree class support
+ optdepends = python2-pyqt4: tree visualization and image rendering
+ optdepends = python2-pyqt5: tree visualization and image rendering
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f02951c7d61a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+_name=ete3
+pkgbase='python-ete'
+pkgname=('python-ete' 'python2-ete')
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="Python toolkit for building, comparing, annotating, manipulating and visualising phylogenetic trees"
+arch=('any')
+url="https://pypi.python.org/pypi/ete"
+license=('GPL3')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+options=(!emptydirs)
+source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/21/17/3c49b7fafe10ed63bb7904ebf9764b98db726aa5fd482fb006818854bc04/ete3-3.1.1.tar.gz)
+sha256sums=('870a3d4b496a36fbda4b13c7c6b9dfa7638384539ae93551ec7acb377fb9c385')
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
+
+package() {
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-ete() {
+ depends=('python2' 'python2-six')
+ optdepends=(
+ 'python2-lxml: Nexml and Phyloxml support'
+ 'python2-numpy: ArrayTable and ClusterTree class support'
+ 'python2-pyqt4: tree visualization and image rendering'
+ 'python2-pyqt5: tree visualization and image rendering'
+ )
+
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}
+
+package_python-ete() {
+ depends=('python' 'python-six')
+ optdepends=(
+ 'python-lxml: Nexml and Phyloxml support'
+ 'python-numpy: ArrayTable and ClusterTree class support'
+ 'python-pyqt4: tree visualization and image rendering'
+ 'python-pyqt5: tree visualization and image rendering'
+ )
+
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}