summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-19 22:52:51 -0500
committerCarlos Aznarán Laos2023-05-19 22:52:51 -0500
commit322c2cb10bfb37bcdd00844280d452e1ed6f0c65 (patch)
tree2127244b9cc366d482f07686c1e5e493c416fe55
parenta49c32e5540b979481c41d8a468cffe3acbf9671 (diff)
downloadaur-322c2cb10bfb37bcdd00844280d452e1ed6f0c65.tar.gz
Bump version to 3.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15bda8c005f0..0a9dfe224a16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-eth-typing
- pkgdesc = Python types for type hinting commonly used Ethereum types.
- pkgver = 2.2.1
+ pkgdesc = Common type annotations for ethereum python packages
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/ethereum/eth-typing
arch = x86_64
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
- source = python-eth-typing-2.2.1.tar.gz::https://github.com/ethereum/eth-typing/archive/v2.2.1.tar.gz
- sha256sums = 6c20477dbd8d2ccc482e8baec00dad129f768bb5d5282f1d1466a90a0e49001d
+ source = eth-typing-3.3.0.tar.gz::https://github.com/ethereum/eth-typing/archive/v3.3.0.tar.gz
+ sha512sums = 1a17723291ef15f5e16f881ccaeab669a957a1557e276907ec970d5af7e59f821f4ae8e8a993e72d37929ab85d54ba4360fbca9699dcd74e43ad218f3b689e72
pkgname = python-eth-typing
-
diff --git a/PKGBUILD b/PKGBUILD
index 14219e7dc1fc..5667a4794eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: algebro <algebro at tuta dot io>
-
-_pkgname=eth-typing
-pkgname=python-$_pkgname
-pkgver=2.2.1
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: algebro <algebro at tuta dot io>
+_base=eth-typing
+pkgname=python-${_base}
+pkgver=3.3.0
pkgrel=1
-pkgdesc="Python types for type hinting commonly used Ethereum types."
-arch=('x86_64')
-url="https://github.com/ethereum/eth-typing"
-license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ethereum/eth-typing/archive/v${pkgver}.tar.gz")
-sha256sums=('6c20477dbd8d2ccc482e8baec00dad129f768bb5d5282f1d1466a90a0e49001d')
+pkgdesc="Common type annotations for ethereum python packages"
+arch=(x86_64)
+url="https://github.com/ethereum/${_base}"
+license=(MIT)
+depends=(python)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('1a17723291ef15f5e16f881ccaeab669a957a1557e276907ec970d5af7e59f821f4ae8e8a993e72d37929ab85d54ba4360fbca9699dcd74e43ad218f3b689e72')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}