summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2019-01-19 14:34:53 -0500
committeralgebro2019-01-19 14:34:53 -0500
commit52831ff062938a71da1336396445cdfc1d97134d (patch)
tree764ec130dfb879c8c40cca19648322bcfb6779a2
downloadaur-52831ff062938a71da1336396445cdfc1d97134d.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec2518c6be43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-eth-typing
+ pkgdesc = Python types for type hinting commonly used Ethereum types.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ethereum/eth-typing
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/ethereum/eth-typing/archive/v2.0.0.tar.gz
+ sha256sums = d3de951ba92077f1610088b3902e42088f7d2142377e466b4520d7cfdad1375e
+
+pkgname = python-eth-typing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83420f88d79e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: algebro <algebro at tuta dot io>
+
+_pkgname=eth-typing
+pkgname=python-$_pkgname
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Python types for type hinting commonly used Ethereum types."
+arch=('x86_64')
+url="https://github.com/ethereum/eth-typing"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/ethereum/eth-typing/archive/v${pkgver}.tar.gz")
+sha256sums=('d3de951ba92077f1610088b3902e42088f7d2142377e466b4520d7cfdad1375e')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}