summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-03 17:43:09 +1100
committerPumpkinCheshire2020-11-03 17:43:09 +1100
commitead869086bb4da47cb2055215b4521b96a2f1aa2 (patch)
tree2dfcf47637acab5e57ed233b4749bf8cea1840c4
parent19a5258d925b3b4bc7ad732e2eb825cd9db96737 (diff)
downloadaur-ead869086bb4da47cb2055215b4521b96a2f1aa2.tar.gz
bump version, add dependencies
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 23 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b96ab4368b..083068fbc802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,27 @@
pkgbase = python-eve-git
pkgdesc = An open source Python REST API framework designed for human beings.
- pkgver = 0.5.r174.ge615518
+ pkgver = 1.1.4.r5.ge1194eb7
pkgrel = 1
url = http://python-eve.org/
arch = any
license = BSD
makedepends = git
makedepends = python-setuptools
+ depends = python-flask
+ depends = python-simplejson
+ depends = python-pymongo
+ depends = python-cerberus
+ depends = python-events
+ optdepends = python-sphinx: docs
+ optdepends = python-sphinx-alabaster-theme: theme for sphinx
+ optdepends = python-doc8: style checker for sphinx
+ optdepends = python-redis: test use
+ optdepends = python-testfixtures: test use
+ optdepends = python-pytest: test use
+ optdepends = python-tox: test use
provides = python-eve
conflicts = python-eve
- options = !emptydirs
- source = git+https://github.com/nicolaiarocci/eve.git
+ source = eve::git+https://github.com/pyeve/eve.git#branch=master
sha256sums = SKIP
pkgname = python-eve-git
diff --git a/PKGBUILD b/PKGBUILD
index 2b4e784954e2..9eecf497c2ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
pkgname=python-eve-git
-pkgver=0.5.r174.ge615518
+pkgver=1.1.4.r5.ge1194eb7
pkgrel=1
+_name=eve
pkgdesc="An open source Python REST API framework designed for human beings."
arch=('any')
url="http://python-eve.org/"
license=('BSD')
+depends=('python-flask' 'python-simplejson' 'python-pymongo' 'python-cerberus' 'python-events')
makedepends=('git' 'python-setuptools')
+optdepends=('python-sphinx: docs' 'python-sphinx-alabaster-theme: theme for sphinx' 'python-doc8: style checker for sphinx' 'python-redis: test use' 'python-testfixtures: test use' 'python-pytest: test use' 'python-tox: test use')
conflicts=('python-eve')
provides=('python-eve')
-options=(!emptydirs)
-source=("git+https://github.com/nicolaiarocci/eve.git")
-_repname=eve
+#source=("git+https://github.com/pyeve/$_name.git")
+source=("$_name::git+https://github.com/pyeve/$_name.git#branch=master")
sha256sums=('SKIP')
pkgver() {
- cd "$_repname"
- # cutting off 'v' prefix that presents in the git tag
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_name"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/$_repname"
+ cd "$srcdir/$_name"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim:set ts=2 sw=2 et: