summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkewl fft2021-05-09 17:48:11 +0100
committerkewl fft2021-05-09 17:48:11 +0100
commit5532f3290aadd69137032583ad63f6a25f3f800a (patch)
tree2e4c45bcea5fcba5f27606960d1d2d3dc8d750e1
downloadaur-5532f3290aadd69137032583ad63f6a25f3f800a.tar.gz
Update to version 3.0.2-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..132930e9fde8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-exchange_calendars
+ pkgdesc = Calendars for various securities exchanges
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://github.com/gerrymanoim/exchange_calendars
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-dateutil
+ depends = python-pytz
+ depends = python-pyluach
+ depends = python-toolz
+ source = https://files.pythonhosted.org/packages/source/e/exchange_calendars/exchange_calendars-3.0.2.tar.gz
+ sha256sums = 9857a5d216fe9c0177a3a5e38d098ceffaa772ce6128c0c01777cd8991087a02
+
+pkgname = python-exchange_calendars
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7e258c5c552
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
+
+pkgname=python-exchange_calendars
+_pkgname=${pkgname#python-}
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Calendars for various securities exchanges"
+arch=('any')
+depends=('python-numpy' 'python-pandas' 'python-dateutil' 'python-pytz' 'python-pyluach' 'python-toolz')
+makedepends=('python-setuptools')
+url="https://github.com/gerrymanoim/$_pkgname"
+license=('APACHE')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('9857a5d216fe9c0177a3a5e38d098ceffaa772ce6128c0c01777cd8991087a02')
+
+build() {
+ cd $_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}