summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-09-13 10:01:46 -0400
committerGuillaume Horel2022-09-13 10:02:10 -0400
commit09a5f1a18ec7c9a82850e229cb300d10d05a6e79 (patch)
tree507727fbda8595d31cd4c7e17be1a0bb0ac4ab84
parent9aae5d0adb9d8c02d48177b0a49e687dc9d5038f (diff)
downloadaur-09a5f1a18ec7c9a82850e229cb300d10d05a6e79.tar.gz
bump to 4.7.6 and fix checkdepends
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD27
3 files changed, 27 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ec4091c4d99..4e80c6356577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = python-exchangelib
pkgdesc = Client for Microsoft Exchange Web Services (EWS)
- pkgver = 4.7.2
+ pkgver = 4.7.6
pkgrel = 1
url = https://github.com/ecederstrand/exchangelib
arch = any
license = BSD
+ checkdepends = python-dateutil
+ checkdepends = python-psutil
checkdepends = python-requests-mock
- makedepends = python-setuptools
+ checkdepends = python-yaml
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-cached-property
depends = python-cryptography
depends = python-defusedxml
@@ -19,9 +24,9 @@ pkgbase = python-exchangelib
depends = python-pytz
depends = python-future
depends = python-tzlocal
- source = python-exchangelib-4.7.2.tar.gz::https://github.com/ecederstrand/exchangelib/archive/refs/tags/v4.7.2.tar.gz
- source = LICENSE
- sha256sums = 12cc787f2e6c8cb15973c3ba4cc6a22bbbc0f0e8e7a9363146d90b1954e67313
- sha256sums = 650d8ac6b0ab9a2c946b021bf12933cad611b6397d0eaff31beb28f6a243afa9
+ source = python-exchangelib-4.7.6.tar.gz::https://github.com/ecederstrand/exchangelib/archive/refs/tags/v4.7.6.tar.gz
+ source = timezone.patch::https://github.com/ecederstrand/exchangelib/commit/d5d386f54adec8ab02f871332b89e1176c214ba2.patch
+ sha256sums = ab8679e5236dd942b09dc8dcbe652d277246d3dfc726b63a8f212589b726c56a
+ sha256sums = 38f92d4435a330e92e165edfea371c66fdc03c85c3e8a2914617a7faff1f9c3e
pkgname = python-exchangelib
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 3594a1aa9cb8..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,23 +0,0 @@
-#Copyright (c) 2009-2016 Erik Cederstrand <erik@cederstrand.dk>.
-#
-#All rights reserved.
-#
-#Redistribution and use in source and binary forms, with or without modification, are
-#permitted provided that the following conditions are met:
-#
-# 1. Redistributions of source code must retain the above copyright notice, this list of
-# conditions and the following disclaimer.
-#
-# 2. Redistributions in binary form must reproduce the above copyright notice, this list
-# of conditions and the following disclaimer in the documentation and/or other materials
-# provided with the distribution.
-#
-#THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER ``AS IS'' AND ANY EXPRESS OR IMPLIED
-#WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
-#FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL <COPYRIGHT HOLDER> OR
-#CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
-#CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-#SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
-#ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
-#NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-#ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index da25f6507254..ff03fc5cafd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,34 @@
# Contributor: Arthur Țițeică | arthur dot titeica with gmail
_pkgname=exchangelib
pkgname=python-exchangelib
-pkgver=4.7.2
+pkgver=4.7.6
pkgrel=1
pkgdesc="Client for Microsoft Exchange Web Services (EWS)"
arch=(any)
url="https://github.com/ecederstrand/exchangelib"
license=('BSD')
depends=('python-cached-property' 'python-cryptography' 'python-defusedxml' 'python-dnspython' 'python-isodate' 'python-lxml' 'python-requests-kerberos' 'python-requests-ntlm' 'python-requests-oauthlib' 'python-pytz' 'python-future' 'python-tzlocal')
-makedepends=('python-setuptools')
-checkdepends=('python-requests-mock')
+makedepends=(python-build python-installer python-wheel)
+checkdepends=(python-dateutil python-psutil python-requests-mock python-yaml)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ecederstrand/exchangelib/archive/refs/tags/v${pkgver}.tar.gz"
-"LICENSE")
-sha256sums=('12cc787f2e6c8cb15973c3ba4cc6a22bbbc0f0e8e7a9363146d90b1954e67313'
- '650d8ac6b0ab9a2c946b021bf12933cad611b6397d0eaff31beb28f6a243afa9')
+ "timezone.patch::https://github.com/ecederstrand/exchangelib/commit/d5d386f54adec8ab02f871332b89e1176c214ba2.patch")
+sha256sums=('ab8679e5236dd942b09dc8dcbe652d277246d3dfc726b63a8f212589b726c56a'
+ '38f92d4435a330e92e165edfea371c66fdc03c85c3e8a2914617a7faff1f9c3e')
+
+prepare() {
+ cd "${_pkgname}-$pkgver"
+ patch -p1 -i ../timezone.patch
+}
build() {
- cd "$srcdir/${_pkgname}-$pkgver"
- python setup.py build
+ cd "${_pkgname}-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${_pkgname}-$pkgver"
- python setup.py install -O1 --skip-build --root="${pkgdir}"
- install -Dm0644 ../../LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "${_pkgname}-$pkgver"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
check() {