summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-04 00:01:14 +0300
committerCaleb Maclennan2023-05-04 00:01:14 +0300
commit177be134c916c2b6215edb69befc78c24803a8d9 (patch)
tree07956f9f83fc53e67ba011810533e1e35d1e9c47
parent9b600000d2ef267e49065397f4e124b6f760f5ad (diff)
downloadaur-177be134c916c2b6215edb69befc78c24803a8d9.tar.gz
upgpkg: python-exif 1.6.0-2
Rebuild for Python 3.11, normalize PEP517 build tooling
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d1ece491982..2137188923d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-exif
pkgdesc = Read and modify image EXIF metadata
pkgver = 1.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/TNThieding/exif
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
depends = python-plum
diff --git a/PKGBUILD b/PKGBUILD
index ae8c615730f2..30fa40986c00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_py_name=exif
pkgname=python-$_py_name
pkgver=1.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='Read and modify image EXIF metadata'
arch=(any)
url="https://gitlab.com/TNThieding/$_py_name"
@@ -12,16 +12,17 @@ _py_deps=(plum)
depends=(python
"${_py_deps[@]/#/python-}")
_archive="$_py_name-$pkgver"
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
source=("https://files.pythonhosted.org/packages/source/${_py_name::1}/$_py_name/$_archive.tar.gz")
sha256sums=('36288d1ffc60030084a04c26f50cc32e19383a36cd234fcfa1fb1c6f698e1d36')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}