summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2019-04-17 00:08:55 +0200
committerspider-mario2019-04-17 00:08:55 +0200
commit4c61b3179ac173d375da1daddbd37dfa54882d3a (patch)
treec04fbf1177fafb41a26feb27eb82f919779358c0
parentb54ca21e568132e1ce39bfb7edbd0301dc13a8b8 (diff)
downloadaur-4c61b3179ac173d375da1daddbd37dfa54882d3a.tar.gz
0.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--undefined-symbol.patch17
3 files changed, 6 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 615e54055bf7..4ea5ba636144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-exiv2
pkgdesc = py3exiv2 is a Python3 binding to exiv2, the C++ library for manipulation of EXIF, IPTC and XMP image metadata.
- pkgver = 0.6.1
+ pkgver = 0.7.0
pkgrel = 1
url = https://launchpad.net/py3exiv2
arch = i686
@@ -10,10 +10,8 @@ pkgbase = python-exiv2
depends = python>=3.7
depends = boost-libs
depends = exiv2
- source = http://www.py3exiv2.tuxfamily.org/releases/python3-exiv2-0.6.1.tar.gz
- source = undefined-symbol.patch
- sha512sums = 605200f4676797c588ccb1af1514a91e76452277a71d34c3d91c6429b094fc23cf51b0d891c7bdcfa46f7e4c9f8abee639beed594c3122c5c3cea495b370a978
- sha512sums = 74a36f445b1c904e07fa294ee425b8015c58b5e424ba9883345b4808b5d1903892ca7169be07f5b208019622bbc5a017e3bae7dfb3448516c04d85a22377026a
+ source = http://www.py3exiv2.tuxfamily.org/releases/python3-exiv2-0.7.0.tar.gz
+ sha512sums = 17bd83fe96c836daf01137c99a2e5bfdf7a506e27570b680cf967469963c161c0ef90d7185801128512ed79f6b64b7fe8f720c00db8ecf00e59c29f6e8766b71
pkgname = python-exiv2
diff --git a/PKGBUILD b/PKGBUILD
index 9b16cbf45d43..e3f1a9290d6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=py3exiv2
pkgname=python-exiv2
-pkgver=0.6.1
+pkgver=0.7.0
pkgrel=1
pkgdesc="py3exiv2 is a Python3 binding to exiv2, the C++ library for manipulation of EXIF, IPTC and XMP image metadata."
url="https://launchpad.net/py3exiv2"
@@ -11,15 +11,8 @@ arch=('i686' 'x86_64')
depends=('python>=3.7' 'boost-libs' 'exiv2')
makedepends=('boost')
license=('GPL3')
-source=("http://www.py3exiv2.tuxfamily.org/releases/python3-exiv2-${pkgver}.tar.gz"
- 'undefined-symbol.patch')
-sha512sums=('605200f4676797c588ccb1af1514a91e76452277a71d34c3d91c6429b094fc23cf51b0d891c7bdcfa46f7e4c9f8abee639beed594c3122c5c3cea495b370a978'
- '74a36f445b1c904e07fa294ee425b8015c58b5e424ba9883345b4808b5d1903892ca7169be07f5b208019622bbc5a017e3bae7dfb3448516c04d85a22377026a')
-
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 < ../undefined-symbol.patch
-}
+source=("http://www.py3exiv2.tuxfamily.org/releases/python3-exiv2-${pkgver}.tar.gz")
+sha512sums=('17bd83fe96c836daf01137c99a2e5bfdf7a506e27570b680cf967469963c161c0ef90d7185801128512ed79f6b64b7fe8f720c00db8ecf00e59c29f6e8766b71')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/undefined-symbol.patch b/undefined-symbol.patch
deleted file mode 100644
index 7509cf28dcc2..000000000000
--- a/undefined-symbol.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff a/src/exiv2wrapper.cpp b/src/exiv2wrapper.cpp
---- a/src/exiv2wrapper.cpp
-+++ b/src/exiv2wrapper.cpp
-@@ -1206,6 +1206,13 @@ Preview::Preview(const Exiv2::PreviewImage& previewImage)
- }
- }
-
-+boost::python::object Preview::getData() const
-+{
-+ return boost::python::object(boost::python::handle<>(
-+ PyBytes_FromStringAndSize(_data.c_str(), _size)
-+ ));
-+}
-+
- void Preview::writeToFile(const std::string& path) const
- {
- std::string filename = path + _extension;