summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-15 23:26:32 -0400
committerJean Lucas2019-08-15 23:26:32 -0400
commitb1a5a3d1e849de7da395859ba23e1df301941789 (patch)
treeb492a7cb0f159a5d936e5a76e1abc18d807454bc
parent3654c53dea92bfb63dde0ef77837f12c5478d249 (diff)
downloadaur-b1a5a3d1e849de7da395859ba23e1df301941789.tar.gz
Update URL, deps; optimize build; reformat
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3970f68aa74..37e8ccb6330a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-expiringdict
pkgdesc = Dictionary with auto-expiring values for caching purposes
pkgver = 1.1.4
- pkgrel = 1
- url = https://pypi.python.org/pypi/expiringdict
+ pkgrel = 2
+ url = https://github.com/mailgun/expiringdict
arch = any
- license = APACHE
+ license = Apache
+ makedepends = python-setuptools
depends = python
source = https://files.pythonhosted.org/packages/source/e/expiringdict/expiringdict-1.1.4.tar.gz
sha256sums = 9275c3f3aa6cabe394355b6454100eb1cdfe395c6b592c26603a2a0f9e3a0587
diff --git a/PKGBUILD b/PKGBUILD
index 1966cba2ec37..69d2b9da75be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
-# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+# Maintainer: Jean Lucas <jean@4ray.co>
+# Contributor: Thomas Weißschuh <thomas t-8ch de>
pkgname=python-expiringdict
-_name=expiringdict
pkgver=1.1.4
-pkgrel=1
+pkgrel=2
pkgdesc='Dictionary with auto-expiring values for caching purposes'
-url='https://pypi.python.org/pypi/expiringdict'
-depends=('python')
-license=('APACHE')
-arch=('any')
-source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz)
+arch=(any)
+url=https://github.com/mailgun/expiringdict
+license=(Apache)
+depends=(python)
+makedepends=(python-setuptools)
+source=(https://files.pythonhosted.org/packages/source/e/expiringdict/expiringdict-$pkgver.tar.gz)
sha256sums=('9275c3f3aa6cabe394355b6454100eb1cdfe395c6b592c26603a2a0f9e3a0587')
-build() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py build
-}
-
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --skip-build
+ cd expiringdict-$pkgver
+ python setup.py install --root="$pkgdir" -O1
}