summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTerin Stock2018-09-20 14:58:03 -0700
committerTerin Stock2018-09-20 14:58:03 -0700
commitda5ff91fa88f57c366fc35cf4095f01d0ccbe439 (patch)
tree32970a7628d5999c5d01f38986a95ac92a7f2f00
downloadaur-da5ff91fa88f57c366fc35cf4095f01d0ccbe439.tar.gz
add package to AUR
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a27c9604da69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-exploitable-git
+ pkgdesc = GDB extension that classifies Linux application bugs by severity
+ pkgver = v1.32.r37.g35b742d
+ pkgrel = 1
+ url = https://github.com/jfoote/exploitable
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ source = python-exploitable-git::git+https://github.com/jfoote/exploitable.git
+ sha256sums = SKIP
+
+pkgname = python-exploitable-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..191fdd1be90a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Terin Stock <terinjokes@gmail.com>
+
+pkgname=python-exploitable-git
+pkgver=1.32.r37.g35b742d
+pkgrel=1
+pkgdesc='GDB extension that classifies Linux application bugs by severity'
+url='https://github.com/jfoote/exploitable'
+arch=('any')
+license=('MIT')
+makedepends=('python-setuptools')
+source=(${pkgname}::git+https://github.com/jfoote/exploitable.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --long | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}
+ python setup.py install -O1 --root="${pkgdir}"
+ rm -rf "${pkgdir}"/usr/lib/python*/site-packages/tests
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm 644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}
+
+# vim: ts=2 sw=2 et: