summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjlaehne2024-10-14 19:05:50 +0200
committerjlaehne2024-10-14 19:05:50 +0200
commite2ef40ee318937246c183d9d9e0aed084a4c40c2 (patch)
tree6200f864842d50a6480b386316f4eb1884620cee
parent269463b312e1f267c615677e321edcfab07a9078 (diff)
downloadaur-e2ef40ee318937246c183d9d9e0aed084a4c40c2.tar.gz
Provides exspy 0.3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58899d1a183f..432004f82579 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-exspy
pkgdesc = Analysis of EDS and EELS data with HyperSpy
- pkgver = 0.2.1
+ pkgver = 0.3
pkgrel = 1
url = http://hyperspy.org/exspy
arch = any
license = GPL3
- makedepends = python-setuptools
- makedepends = python-setuptools-scm
+ makedepends = python-setuptools>=64
+ makedepends = python-setuptools-scm>=8
+ makedepends = python-wheel
depends = python
depends = python-dask
depends = python-hyperspy>=2.0rc0
@@ -32,7 +33,7 @@ pkgbase = python-exspy
optdepends = python-sphinxcontrib-mermaid: build documentation
optdepends = python-sphinxcontrib-towncrier
provides = exspy
- source = https://github.com/hyperspy/exspy/archive/v0.2.1.tar.gz
- md5sums = 1401cbc6bf9b73ded770ec4e75c2068c
+ source = https://github.com/hyperspy/exspy/archive/v0.3.tar.gz
+ md5sums = dbac0c579c24d74e0a9fa05a54d178ef
pkgname = python-exspy
diff --git a/PKGBUILD b/PKGBUILD
index db68a43cd19c..1778aa5e92e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jonas Lähnemann <jonas at pdi-berlin dot de>
pkgname=python-exspy
pkgshort=exspy
-pkgver=0.2.1
+pkgver=0.3
pkgrel=1
pkgdesc="Analysis of EDS and EELS data with HyperSpy"
arch=('any')
@@ -13,7 +13,7 @@ depends=('python'
'python-dask'
'python-hyperspy>=2.0rc0'
'python-matplotlib'
- 'python-numexpr'
+ 'python-numexpr' # speed
'python-numpy'
'python-pint'
'python-pooch'
@@ -38,8 +38,10 @@ optdepends=('python-hyperspy-gui-ipywidgets>=2.0: GUI components for Jupyter' #
)
-makedepends=('python-setuptools'
- 'python-setuptools-scm')
+makedepends=('python-setuptools>=64'
+ 'python-setuptools-scm>=8'
+ 'python-wheel'
+ )
provides=('exspy')
@@ -56,4 +58,4 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
}
-md5sums=('1401cbc6bf9b73ded770ec4e75c2068c')
+md5sums=('dbac0c579c24d74e0a9fa05a54d178ef')