summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-01-08 15:16:58 +0800
committerUniversebenzene2020-01-08 15:16:58 +0800
commit18fed1b3e5f192948aad8d3d8563e047393cfd47 (patch)
tree2221f6e86d3ec2670b4f471057c9e64756a66dfe
parentbc60aa5b883e99c1c475d2922b4178fb78a6dedd (diff)
downloadaur-18fed1b3e5f192948aad8d3d8563e047393cfd47.tar.gz
Update to version 0.4.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec9157b1b7b6..61452dc352cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
-# Generated by mksrcinfo v8
-# Wed Jan 23 15:13:59 UTC 2019
pkgbase = python-extinction
pkgdesc = Fast interstellar dust extinction laws in Python
- pkgver = 0.4.0
+ pkgver = 0.4.2
pkgrel = 1
url = http://extinction.readthedocs.io/
arch = i686
arch = x86_64
license = MIT
- makedepends = python-setuptools
- makedepends = python2-setuptools
+ makedepends = cython
+ makedepends = cython2
makedepends = python-numpy
makedepends = python2-numpy
- source = https://files.pythonhosted.org/packages/source/e/extinction/extinction-0.4.0.tar.gz
- md5sums = f67c418793a4b44b4075af6d2f9b742b
+ source = https://files.pythonhosted.org/packages/source/e/extinction/extinction-0.4.2.tar.gz
+ md5sums = a79209dc264c4d1a4a1c4fcbc37ec611
pkgname = python-extinction
- depends = python-numpy
+ depends = python-numpy>=1.13.3
pkgname = python2-extinction
- depends = python2-numpy
+ depends = python2-numpy>=1.13.3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e896dcd6056d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index e055a38c1747..5c977620dc75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgbase=python-extinction
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}")
-pkgver=0.4.0
+pkgver=0.4.2
pkgrel=1
pkgdesc="Fast interstellar dust extinction laws in Python"
arch=('i686' 'x86_64')
url="http://extinction.readthedocs.io/"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools' 'python-numpy' 'python2-numpy')
+makedepends=('cython' 'cython2' 'python-numpy' 'python2-numpy')
#checkdepends=('python-pytest' 'python2-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('f67c418793a4b44b4075af6d2f9b742b')
+md5sums=('a79209dc264c4d1a4a1c4fcbc37ec611')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -40,7 +40,7 @@ check() {
}
package_python2-extinction() {
- depends=('python2-numpy')
+ depends=('python2-numpy>=1.13.3')
cd ${srcdir}/${_pyname}-${pkgver}-py2
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
@@ -49,7 +49,7 @@ package_python2-extinction() {
}
package_python-extinction() {
- depends=('python-numpy')
+ depends=('python-numpy>=1.13.3')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"