summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsasvari2017-06-05 17:55:01 +0200
committersasvari2017-06-05 17:55:01 +0200
commitc5239235e403fef38cd06e043fff996ce7a329b3 (patch)
tree61e8ccca3e4ce894f1c2651fcfaf26fbfed7f645
downloadaur-c5239235e403fef38cd06e043fff996ce7a329b3.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
3 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2186bb5a084b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-ezdxf
+ pkgdesc = A Python package to create/manipulate DXF drawings.
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = http://ezdxf.readthedocs.io/
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/mozman/ezdxf/archive/v0.8.2.tar.gz
+ sha256sums = 60ebedbb0c6ec3071af81f01247a3e09afef0c325b7448fb409331755a844008
+
+pkgname = python-ezdxf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..586ab77b9cde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: sasvari <sasvari@fastmail.com>
+pkgname=python-ezdxf
+_pkgname=ezdxf
+pkgver=0.8.2
+pkgrel=1
+pkgdesc="A Python package to create/manipulate DXF drawings."
+arch=(any)
+url="http://ezdxf.readthedocs.io/"
+license=('MIT')
+depends=('python')
+sha256sums=('60ebedbb0c6ec3071af81f01247a3e09afef0c325b7448fb409331755a844008')
+source=("https://github.com/mozman/$_pkgname/archive/v$pkgver.tar.gz")
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --optimize=1 --root="$pkgdir/" --prefix="/usr"
+}