summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonid Bloch2017-01-09 21:11:15 +0200
committerLeonid Bloch2017-01-09 21:11:15 +0200
commitb604188eda1d1f61b5dd95d44b02756b95fbb5ac (patch)
treea64ffc91b01c42c618929de3007d6dbf9139861e
parent5c2edb646f36176d4e4c5a8ce41f72e31019b6b8 (diff)
downloadaur-b604188eda1d1f61b5dd95d44b02756b95fbb5ac.tar.gz
PKGBUILD fixes
1) sha1sums replaced with sha256sums 2) Unnecessary paths to srcdir removed. These changes do not effect the installed package whatsoever, therefore pkgrel is not incremented. Signed-off-by: Leonid Bloch <leonid.bloch@esrf.fr>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e528804e5d3..f78a8f6aaef3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = python-fabio
depends = python-lxml
optdepends = python-pyqt4: for the fabio_viewer program
source = https://github.com/silx-kit/fabio/archive/v0.4.0.tar.gz
- sha1sums = c0ca0a6935e9213b567fdcfa77da05900a1abbc3
+ sha256sums = ae1f2f979f801524558cac81ec8988d1eadce65b540cdeb46166162ae4788956
pkgname = python-fabio
diff --git a/PKGBUILD b/PKGBUILD
index d7b31d18ac8f..ace17a301263 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,15 +11,15 @@ depends=('python-numpy' 'python-pillow' 'python-lxml')
optdepends=('python-pyqt4: for the fabio_viewer program')
makedepends=('git')
source=("https://github.com/silx-kit/${pkgname#*-}/archive/v${pkgver}.tar.gz")
-sha1sums=('c0ca0a6935e9213b567fdcfa77da05900a1abbc3')
+sha256sums=('ae1f2f979f801524558cac81ec8988d1eadce65b540cdeb46166162ae4788956')
build() {
- cd "${srcdir}/${pkgname#*-}-${pkgver}"
+ cd "${pkgname#*-}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${pkgname#*-}-${pkgver}"
+ cd "${pkgname#*-}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -D copyright "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}