summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-06-16 15:49:45 +0200
committerPhilip Goto2018-06-16 15:49:45 +0200
commit21cd92512ed9952d1ee622c6114c96e8509a0331 (patch)
tree6b58aaccf2296a913b52413aeb1abaad7fd184e5
downloadaur-21cd92512ed9952d1ee622c6114c96e8509a0331.tar.gz
Initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca25e2899bc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-face_recognition
+ pkgdesc = The world's simplest facial recognition api for Python and the command line
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/ageitgey/face_recognition
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-dlib-cuda
+ depends = python-face_recognition_models
+ source = https://files.pythonhosted.org/packages/e1/da/b607fc6c80eb8e82487b1cb3cff445450d712eb0456f562790c7a761f781/face_recognition-1.2.2.tar.gz
+ sha256sums = f70d92c8582113fed669832cd8036819b66eebf4a535b1b43b1c0cede0072fb7
+
+pkgname = python-face_recognition
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efc80d07ed3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+_pkgname=face_recognition
+pkgname=python-$_pkgname
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="The world's simplest facial recognition api for Python and the command line"
+url="https://github.com/ageitgey/face_recognition"
+depends=('python-dlib-cuda'
+ 'python-face_recognition_models')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/e1/da/b607fc6c80eb8e82487b1cb3cff445450d712eb0456f562790c7a761f781/face_recognition-1.2.2.tar.gz")
+sha256sums=('f70d92c8582113fed669832cd8036819b66eebf4a535b1b43b1c0cede0072fb7')
+
+build(){
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py build
+}
+
+package(){
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+}