summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2015-07-08 08:03:46 -0400
committerJeremy Audet2015-07-08 08:03:46 -0400
commit52713af96b6ce5eac3296c66808c34f547d966b9 (patch)
tree3c78aa8449079499069137dcfc04622bebf44114
downloadaur-52713af96b6ce5eac3296c66808c34f547d966b9.tar.gz
Initial commit (version 2.5.2)
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD32
-rwxr-xr-xprint-version.py11
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..074410ec1edc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-factory_boy
+ pkgdesc = A fixtures replacement based on thoughtbot's factory_girl for Ruby.
+ pkgver = 2.5.2
+ pkgrel = 1
+ url = https://github.com/rbarrois/factory_boy
+ arch = any
+ license = MIT
+ makedepends = python-distribute
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/f/factory_boy/factory_boy-2.5.2.tar.gz
+ source = LICENSE
+ sha256sums = cd8306e64c3a115deca136685e945db88ffe171382012ec938ed241a20dd7eba
+ sha256sums = a57c71972eb450d03a3ef6eb8ae32bcdb9fcc485c11c52ee1032a2b0c107f714
+
+pkgname = python-factory_boy
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..620dc61fbaf0
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright (c) 2010 Mark Sandstrom
+Copyright (c) 2011-2013 Raphaƫl Barrois
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..339954153d22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jeremy "Ichimonji10" Audet <ichimonji10 at gmail dot com>
+#
+# namcap warns that python is an unnecessary dependency. This is untrue.
+
+pkgname=python-factory_boy
+_pkgname="${pkgname#python-}"
+pkgver=2.5.2
+pkgrel=1
+pkgdesc="A fixtures replacement based on thoughtbot's factory_girl for Ruby."
+arch=(any)
+url='https://github.com/rbarrois/factory_boy'
+license=(MIT)
+depends=(python)
+makedepends=(python-distribute)
+options=(!emptydirs)
+source=(
+ "https://pypi.python.org/packages/source/f/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ LICENSE
+)
+
+sha256sums=('cd8306e64c3a115deca136685e945db88ffe171382012ec938ed241a20dd7eba'
+ 'a57c71972eb450d03a3ef6eb8ae32bcdb9fcc485c11c52ee1032a2b0c107f714')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm 644 \
+ "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/print-version.py b/print-version.py
new file mode 100755
index 000000000000..e7ada5224ae3
--- /dev/null
+++ b/print-version.py
@@ -0,0 +1,11 @@
+#!/usr/bin/env python
+"""Print the Factory Boy version.
+
+This script exists soley for the convenience of the package maintainer.
+
+"""
+import factory
+import sys
+
+print('Python version: {}'.format(sys.version))
+print('Factory Boy version: {}'.format(factory.__version__))