summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Müllenhaupt2017-06-09 12:54:50 +0200
committerMartin Müllenhaupt2017-06-09 12:54:50 +0200
commit2ce37a362b6a9f1ade8f984b64ceb70cee42b448 (patch)
treeff3f508aca93b166034e878a32cb2b78656ccba8
downloadaur-2ce37a362b6a9f1ade8f984b64ceb70cee42b448.tar.gz
init
-rw-r--r--.SRCINFO35
-rw-r--r--FAForeverPy36.desktop9
-rw-r--r--PKGBUILD46
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc9784deba49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Fri Jun 9 10:54:36 UTC 2017
+pkgbase = python-fafclient
+ pkgdesc = Forged Alliance Forever - Lobby Client. Community-driven client system for Supreme Commander: Forged Alliance.
+ pkgver = 0.12.5.19.gf89d4f0c
+ pkgrel = 1
+ epoch = 0
+ url = http://www.faforever.com/
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-pyqt5
+ depends = python-ipaddress
+ depends = python-py
+ depends = python-pycparser
+ depends = python-dateutil
+ depends = python-requests
+ depends = python-lupa
+ depends = python-trueskill
+ depends = python-cffi
+ depends = python-marshmallow-jsonapi
+ depends = python-semantic-version
+ depends = python-faftools
+ depends = lib32-libpulse
+ depends = wine>1.6.0
+ depends = xdelta3
+ depends = faf-uid
+ depends = faf-res
+ source = git+https://github.com/FAForever/client.git#branch=474-feature-py3
+ source = FAForeverPy36.desktop
+ sha256sums = SKIP
+ sha256sums = 460f1d4d4e7a94f5c2c4f5d1e92014a97f63cc3512a019e4206e1b85ad57b544
+
+pkgname = python-fafclient
+
diff --git a/FAForeverPy36.desktop b/FAForeverPy36.desktop
new file mode 100644
index 000000000000..e11689ff8e80
--- /dev/null
+++ b/FAForeverPy36.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=FAForever
+Comment=Supreme Commander Forged Alliance game lobby
+Exec=python /usr/lib/python3.6/site-packages/fafclient
+Icon=/usr/share/fafclient/window_icon.png
+Terminal=false
+Categories=Games
+Path=/usr/share/fafclient
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cb3ff2cdf68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Martin Müllenhaupt <mm+aur.archlinux.org@netlair.de>
+pkgname=python-fafclient
+pkgver=0.12.5.19.gf89d4f0c
+pkgrel=1
+epoch=0
+pkgdesc="Forged Alliance Forever - Lobby Client. Community-driven client system for Supreme Commander: Forged Alliance."
+url="http://www.faforever.com/"
+arch=('any')
+license=('GPL3')
+groups=()
+depends=('python-pyqt5' 'python-ipaddress' 'python-py' 'python-pycparser' 'python-dateutil' 'python-requests' 'python-lupa' 'python-trueskill' 'python-cffi' 'python-marshmallow-jsonapi' 'python-semantic-version' 'python-faftools' 'lib32-libpulse' 'wine>1.6.0' 'xdelta3' 'faf-uid' 'faf-res')
+makedepends=('python-setuptools')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/FAForever/client.git#branch=474-feature-py3" 'FAForeverPy36.desktop')
+sha256sums=('SKIP'
+ '460f1d4d4e7a94f5c2c4f5d1e92014a97f63cc3512a019e4206e1b85ad57b544')
+noextract=()
+validpgpkeys=()
+
+pkgver() {
+ cd "client"
+ git describe --tags | sed -e 's/-/./g'
+}
+prepare() {
+ cd "client"
+ mv src fafclient
+}
+
+build() {
+ cd "client"
+ FAFCLIENT_VERSION=$pkgver python setup.py build
+}
+
+package() {
+ cd "client"
+ FAFCLIENT_VERSION=$pkgver python setup.py install --root="$pkgdir" --optimize=1
+ install -D "$srcdir/FAForeverPy36.desktop" "$pkgdir/usr/share/applications/FAForeverPy36.desktop"
+}