summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Hahler2016-11-30 16:33:05 +0100
committerDaniel Hahler2016-11-30 16:33:05 +0100
commitd31ac6f90cdd506dead79abb76a3f4793695b23e (patch)
treefdbe80c3259e10d24db7e00e51000cf0c50b8640
parentc8c47e7bd6723b1a1fbbe0e84e76b3ec168c32de (diff)
downloadaur-d31ac6f90cdd506dead79abb76a3f4793695b23e.tar.gz
Update to 0.7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--fix-py3-unicode-str.patch22
3 files changed, 10 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de9d5192c470..56cfa58c7b26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = python-fancycompleter
pkgdesc = Colorful TAB completion for Python prompt
- pkgver = 0.5
- pkgrel = 2
+ pkgver = 0.7
+ pkgrel = 1
url = https://bitbucket.org/antocuni/fancycompleter
install = python-fancycompleter.install
arch = any
- license = GPL
+ license = BSD
depends = python
optdepends = python-pyrepl-hg
- source = https://pypi.python.org/packages/2d/4c/753646af3c4eafc6a4e4a0886f1becd09ddb3bb179bd3c350d8ac357b29a/fancycompleter-0.5.tar.gz
- source = fix-py3-unicode-str.patch
- md5sums = 5eacad3b56b3b6a8435af44df7899e65
- md5sums = 1a2d75376f69e08fd9cd6efc222489c8
+ source = https://pypi.python.org/packages/93/33/0fc5fd5ffcd05e60af4f923d0d722e280a3ea348c00f25d0081c794e075c/fancycompleter-0.7.tar.gz
+ md5sums = fc140f78fa6afe923698cf469df42abd
pkgname = python-fancycompleter
diff --git a/PKGBUILD b/PKGBUILD
index dc57e2e377af..fd4d365f2f54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,18 @@
# Based on https://aur.archlinux.org/packages/python2-fancycompleter
pkgname=python-fancycompleter
_realpkg=fancycompleter
-pkgver=0.5
-pkgrel=2
+pkgver=0.7
+pkgrel=1
pkgdesc="Colorful TAB completion for Python prompt"
arch=("any")
url="https://bitbucket.org/antocuni/fancycompleter"
-license=('GPL')
+license=('BSD')
depends=('python')
# pyrepl is optional, and buggy on py3.
optdepends=('python-pyrepl-hg')
install="$pkgname.install"
-source=("https://pypi.python.org/packages/2d/4c/753646af3c4eafc6a4e4a0886f1becd09ddb3bb179bd3c350d8ac357b29a/${_realpkg}-${pkgver}.tar.gz"
- 'fix-py3-unicode-str.patch')
-md5sums=('5eacad3b56b3b6a8435af44df7899e65'
- '1a2d75376f69e08fd9cd6efc222489c8')
-
-prepare() {
- cd "$srcdir/$_realpkg-$pkgver"
- patch -Np1 < ../fix-py3-unicode-str.patch
-}
+source=("https://pypi.python.org/packages/93/33/0fc5fd5ffcd05e60af4f923d0d722e280a3ea348c00f25d0081c794e075c/${_realpkg}-${pkgver}.tar.gz")
+md5sums=('fc140f78fa6afe923698cf469df42abd')
package() {
cd "$srcdir/$_realpkg-$pkgver"
diff --git a/fix-py3-unicode-str.patch b/fix-py3-unicode-str.patch
deleted file mode 100644
index d5b55f4ecd49..000000000000
--- a/fix-py3-unicode-str.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-# Fix TAB completion on objects in Python 3.
-# Source: https://bitbucket.org/antocuni/fancycompleter/issues/4/05-breaks-tab-completion-in-pdbpp-on#comment-28234453
---- a/fancycompleter.py Sun Oct 05 12:25:21 2014 +0200
-+++ b/fancycompleter.py Thu Jun 02 19:51:05 2016 +0200
-@@ -31,7 +31,7 @@
- try:
- unicode
- except NameError:
-- unicode = str
-+ unicode = object()
-
- # ----------------------
-
-@@ -219,7 +219,7 @@
- values = []
- n = len(attr)
- for word in dir(object):
-- if isinstance(word, unicode):
-+ if not isinstance(word, str) and isinstance(word, unicode):
- # this is needed because pyrepl doesn't like unicode
- # completions: as soon as it finds something which is not str,
- # it stops.