aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorbius2024-02-21 14:24:30 +0100
committerMorbius2024-02-21 14:24:30 +0100
commitcade54fb55b51ef30d65b0be8017ad6a39cac0cd (patch)
tree57396f9e42bdba82ed7eaef00f672b40395b49ea
parente5554f51f9c4703bb437ca6389dc2ba3c62f37bf (diff)
downloadaur-cade54fb55b51ef30d65b0be8017ad6a39cac0cd.tar.gz
Include shellcheck recommendations
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96ac17c2a4de..db28c92a7082 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,12 +25,12 @@ backup=('etc/fangfrisch/fangfrisch.conf')
install=fangfrisch.install
build() {
- cd "$_name-$pkgver"
+ cd "$_name-$pkgver" || exit 1
python -m build --wheel --no-isolation
}
check() {
- cd "$_name-$pkgver"
+ cd "$_name-$pkgver" || exit 1
rm -rf tmp_unittest
mkdir -p tmp_unittest
sed -i -e "s,/tmp/fangfrisch/unittest,$srcdir/$_name-$pkgver/tmp_unittest," tests/tests.conf tests/__init__.py
@@ -40,7 +40,7 @@ check() {
}
package() {
- cd "$_name-$pkgver"
+ cd "$_name-$pkgver" || exit 1
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 -t "${pkgdir}/etc/fangfrisch" "${srcdir}/${_name}.conf"
install -Dm644 -t "${pkgdir}/usr/lib/systemd/system" "${srcdir}/${_name}".{service,timer}