summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-01-13 14:06:45 -0500
committerGuillaume Horel2017-01-13 14:06:45 -0500
commit8698991bb2ac6b32cbbb72347b3a193c0b47f49e (patch)
treeda8d10901d30208539c11b4a790beda537081383
parent887b2697412f2bdd664c6d41a2337b9112a5a2d0 (diff)
downloadaur-8698991bb2ac6b32cbbb72347b3a193c0b47f49e.tar.gz
install license
-rw-r--r--.SRCINFO2
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD8
3 files changed, 29 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44e43748bde3..096ed731b035 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,9 @@ pkgbase = python-fastcache
makedepends = python-setuptools
depends = python
source = https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz
+ source = LICENSE
md5sums = 1c301bedd2be2ae48d9c853ca7719e19
+ md5sums = cb0f95fac11cd4c86c8a27cdda8e26f8
pkgname = python-fastcache
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..71d4c5f7deef
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Peter Brady
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 4dce920bfa0e..23aace380b13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-fastcache')
_module='fastcache'
pkgver='1.0.2'
@@ -8,8 +9,10 @@ depends=('python')
makedepends=('python-setuptools')
license=('MIT')
arch=('i686' 'x86_64')
-source=("https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz")
-md5sums=('1c301bedd2be2ae48d9c853ca7719e19')
+source=("https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz"
+ "LICENSE")
+md5sums=('1c301bedd2be2ae48d9c853ca7719e19'
+ 'cb0f95fac11cd4c86c8a27cdda8e26f8')
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -17,6 +20,7 @@ build() {
}
package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}