summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-05-01 13:13:51 -0400
committerGuillaume Horel2019-05-01 13:13:51 -0400
commitaa7d4f0b5cb8f1d720e05d445ab832c7ef2efb81 (patch)
tree81d1fdbf9385d9647e0cc84682460ed5bd2634d5
parentbdb85f698a387c8d54a70ae51d76b4335a28d30d (diff)
downloadaur-aa7d4f0b5cb8f1d720e05d445ab832c7ef2efb81.tar.gz
version bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e66be1b6df42..1d450d7234a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = python-fastcache
pkgdesc = C implementation of Python 3 functools.lru_cache.
- pkgver = 1.0.2
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/pbrady/fastcache
- arch = i686
arch = x86_64
license = MIT
checkdepends = python-pytest
makedepends = python-setuptools
depends = python
- source = https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz
+ source = https://pypi.org/packages/source/f/fastcache/fastcache-1.1.0.tar.gz
source = LICENSE
- sha256sums = 867005774917f999854ffd303fbe3793c30c2dc9279b78ec315dd4e57e4284e6
+ sha256sums = 6de1b16e70335b7bde266707eb401a3aaec220fb66c5d13b02abf0eab8be782b
sha256sums = 023e92e0b6343c75e6912abd5076ea28b520ca27d1cd44497bcf363b9b8f559d
pkgname = python-fastcache
diff --git a/PKGBUILD b/PKGBUILD
index 3240d3842368..7a04734df993 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-fastcache')
-_module='fastcache'
-pkgver='1.0.2'
+_pkgname='fastcache'
+pkgver='1.1.0'
pkgrel=1
pkgdesc="C implementation of Python 3 functools.lru_cache."
url="https://github.com/pbrady/fastcache"
@@ -9,25 +9,25 @@ checkdepends=('python-pytest')
depends=('python')
makedepends=('python-setuptools')
license=('MIT')
-arch=('i686' 'x86_64')
-source=("https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz"
+arch=('x86_64')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
"LICENSE")
-sha256sums=('867005774917f999854ffd303fbe3793c30c2dc9279b78ec315dd4e57e4284e6'
+sha256sums=('6de1b16e70335b7bde266707eb401a3aaec220fb66c5d13b02abf0eab8be782b'
'023e92e0b6343c75e6912abd5076ea28b520ca27d1cd44497bcf363b9b8f559d')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
}
check() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build_ext --inplace
pytest
}
package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}