summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-03-13 16:17:28 -0400
committerGuillaume Horel2017-03-13 16:17:28 -0400
commitbdb85f698a387c8d54a70ae51d76b4335a28d30d (patch)
tree9844e0b247c6c6bb9cb9de9276c7ddf08db3917e
parent8698991bb2ac6b32cbbb72347b3a193c0b47f49e (diff)
downloadaur-bdb85f698a387c8d54a70ae51d76b4335a28d30d.tar.gz
add check()
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 096ed731b035..e66be1b6df42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,13 @@ pkgbase = python-fastcache
arch = i686
arch = x86_64
license = MIT
+ checkdepends = python-pytest
makedepends = python-setuptools
depends = python
source = https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz
source = LICENSE
- md5sums = 1c301bedd2be2ae48d9c853ca7719e19
- md5sums = cb0f95fac11cd4c86c8a27cdda8e26f8
+ sha256sums = 867005774917f999854ffd303fbe3793c30c2dc9279b78ec315dd4e57e4284e6
+ sha256sums = 023e92e0b6343c75e6912abd5076ea28b520ca27d1cd44497bcf363b9b8f559d
pkgname = python-fastcache
diff --git a/PKGBUILD b/PKGBUILD
index 23aace380b13..3240d3842368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,27 @@ pkgver='1.0.2'
pkgrel=1
pkgdesc="C implementation of Python 3 functools.lru_cache."
url="https://github.com/pbrady/fastcache"
+checkdepends=('python-pytest')
depends=('python')
makedepends=('python-setuptools')
license=('MIT')
arch=('i686' 'x86_64')
source=("https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz"
"LICENSE")
-md5sums=('1c301bedd2be2ae48d9c853ca7719e19'
- 'cb0f95fac11cd4c86c8a27cdda8e26f8')
+sha256sums=('867005774917f999854ffd303fbe3793c30c2dc9279b78ec315dd4e57e4284e6'
+ '023e92e0b6343c75e6912abd5076ea28b520ca27d1cd44497bcf363b9b8f559d')
build() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py build
}
+check() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build_ext --inplace
+ pytest
+}
+
package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${srcdir}/${_module}-${pkgver}"