summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-01-10 13:25:28 -0500
committerGuillaume Horel2017-01-10 13:25:28 -0500
commitf9d944ea9a34a4e1b835bf03410ad7ec3b6143ec (patch)
treeed11c7c3f1f4b4f7bfa782a6d3088818e93e445b
downloadaur-f9d944ea9a34a4e1b835bf03410ad7ec3b6143ec.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a3fa9dc7f18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-fastcache
+ pkgdesc = C implementation of Python 3 functools.lru_cache.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/pbrady/fastcache
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz
+ md5sums = 1c301bedd2be2ae48d9c853ca7719e19
+
+pkgname = python-fastcache
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad6610123c5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase=('python-fastcache')
+pkgname=('python-fastcache')
+_module='fastcache'
+pkgver='1.0.2'
+pkgrel=1
+pkgdesc="C implementation of Python 3 functools.lru_cache."
+url="https://github.com/pbrady/fastcache"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('i686' 'x86_64')
+source=("https://pypi.python.org/packages/fb/98/93f2d36738868e8dd5a8dbfc918169b24658f63e5fa041fe000c22ae4f8b/fastcache-1.0.2.tar.gz")
+md5sums=('1c301bedd2be2ae48d9c853ca7719e19')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}