summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-20 14:55:51 -0800
committerclintval2018-01-20 14:55:51 -0800
commit18cbaf6781283060777d545714027efdf650b3fb (patch)
treee4b8e8e2796d4d77699b1c5a076f4db41a6e7c8e
parentf7718413973661efa4a4e3dcf719defd38015310 (diff)
downloadaur-18cbaf6781283060777d545714027efdf650b3fb.tar.gz
python-fastcluster to split package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
2 files changed, 52 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 162ca396bb05..9a91dcc66e00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = python-fastcluster
- pkgdesc = Fast hierarchical clustering routines for R and Python.
+ pkgdesc = Fast hierarchical clustering routines for R and Python
pkgver = 1.1.24
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.python.org/pypi/fastcluster
arch = any
license = BSD
+ makedepends = python
makedepends = python-setuptools
- depends = python
- depends = python-numpy>=1.9.2
- provides = python-fastcluster
- conflicts = python-fastcluster
+ makedepends = python2
+ makedepends = python2-setuptools
options = !emptydirs
- source = https://pypi.python.org/packages/1e/00/9910dd324f32582051d0ee6922c3cd4727234aae96366f3867c46a70cd78/fastcluster-1.1.24.tar.gz
- md5sums = e71235732f43f5f19d71cfaf3b45ff0c
+ source = python-fastcluster-1.1.24.tar.gz::https://pypi.python.org/packages/1e/00/9910dd324f32582051d0ee6922c3cd4727234aae96366f3867c46a70cd78/fastcluster-1.1.24.tar.gz
+ sha256sums = a5d1922b1db6f4c3012416e7dc14de2984b9335a48c895e1698afd5c718312b0
pkgname = python-fastcluster
+ depends = python
+ depends = python-numpy
+
+pkgname = python2-fastcluster
+ depends = python2
+ depends = python2-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 287c122de12e..dcf104c7d229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,50 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-pkgname='python-fastcluster'
+_name=fastcluster
+pkgbase='python-fastcluster'
+pkgname=('python-fastcluster' 'python2-fastcluster')
pkgver=1.1.24
-pkgrel=1
-pkgdesc="Fast hierarchical clustering routines for R and Python."
+pkgrel=2
+pkgdesc="Fast hierarchical clustering routines for R and Python"
arch=('any')
url="https://pypi.python.org/pypi/fastcluster"
license=('BSD')
-depends=('python' 'python-numpy>=1.9.2')
-makedepends=('python-setuptools')
-provides=('python-fastcluster')
-conflicts=('python-fastcluster')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/1e/00/9910dd324f32582051d0ee6922c3cd4727234aae96366f3867c46a70cd78/fastcluster-${pkgver}.tar.gz")
-md5sums=('e71235732f43f5f19d71cfaf3b45ff0c')
+source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/1e/00/9910dd324f32582051d0ee6922c3cd4727234aae96366f3867c46a70cd78/fastcluster-1.1.24.tar.gz)
+sha256sums=('a5d1922b1db6f4c3012416e7dc14de2984b9335a48c895e1698afd5c718312b0')
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
package() {
- cd "${srcdir}/fastcluster-${pkgver}"
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-fastcluster() {
+ depends=('python2' 'python2-numpy')
+
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ install -Dm644 COPYING.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+}
+
+package_python-fastcluster() {
+ depends=('python' 'python-numpy')
+
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ install -Dm644 COPYING.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+}