summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-18 17:37:02 -0500
committerclintval2017-12-18 17:37:02 -0500
commitf7718413973661efa4a4e3dcf719defd38015310 (patch)
tree67abf6869508612bbe2b500de3485f6a6a502c4d
downloadaur-f7718413973661efa4a4e3dcf719defd38015310.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..162ca396bb05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-fastcluster
+ pkgdesc = Fast hierarchical clustering routines for R and Python.
+ pkgver = 1.1.24
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/fastcluster
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy>=1.9.2
+ provides = python-fastcluster
+ conflicts = python-fastcluster
+ options = !emptydirs
+ source = https://pypi.python.org/packages/1e/00/9910dd324f32582051d0ee6922c3cd4727234aae96366f3867c46a70cd78/fastcluster-1.1.24.tar.gz
+ md5sums = e71235732f43f5f19d71cfaf3b45ff0c
+
+pkgname = python-fastcluster
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..287c122de12e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-fastcluster'
+pkgver=1.1.24
+pkgrel=1
+pkgdesc="Fast hierarchical clustering routines for R and Python."
+arch=('any')
+url="https://pypi.python.org/pypi/fastcluster"
+license=('BSD')
+depends=('python' 'python-numpy>=1.9.2')
+makedepends=('python-setuptools')
+provides=('python-fastcluster')
+conflicts=('python-fastcluster')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/1e/00/9910dd324f32582051d0ee6922c3cd4727234aae96366f3867c46a70cd78/fastcluster-${pkgver}.tar.gz")
+md5sums=('e71235732f43f5f19d71cfaf3b45ff0c')
+
+package() {
+ cd "${srcdir}/fastcluster-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}