summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Sachweh2018-03-31 10:59:07 +0200
committerConrad Sachweh2018-03-31 10:59:07 +0200
commita870aabc06efba8384da78f18cd67389df7188b4 (patch)
tree13ff90ea4880dcfeb8b7691434145ec68e58fe2b
downloadaur-a870aabc06efba8384da78f18cd67389df7188b4.tar.gz
initial upload v0.3.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97c00556b8d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-fastdtw
+ pkgdesc = Python implementation of FastDTW, whis is an approximate Dynamic Time Warping (DTW) algorithm that provides optimal or near-optimal alignments with an O(N) time and memory complexity.
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/slaypni/fastdtw
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/f/fastdtw/fastdtw-0.3.2.tar.gz
+ md5sums = 63d55d14dbc4a40d2d1ceecb756d0ee4
+
+pkgname = python-fastdtw
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..84ad39682cb2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+*.tar
+*.xz
+*.gz
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69bfad09903f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Conrad Sachweh <conrad+aur@spamthis.space>
+pkgname=python-fastdtw
+_pkgname=fastdtw
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="Python implementation of FastDTW, whis is an approximate Dynamic Time Warping (DTW) algorithm that provides optimal or near-optimal alignments with an O(N) time and memory complexity."
+url="https://github.com/slaypni/fastdtw"
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('63d55d14dbc4a40d2d1ceecb756d0ee4')
+
+package() {
+ cd $srcdir/${_pkgname}-${pkgver}
+
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}