summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-19 17:56:49 -0500
committerLuis Martinez2021-09-19 17:56:49 -0500
commitf3da5ca16a66e018fa1546a6579e52e3f044dcb2 (patch)
treee7161b48efafbeff393ab0d630ed7cb2e78d2746
parenta870aabc06efba8384da78f18cd67389df7188b4 (diff)
downloadaur-f3da5ca16a66e018fa1546a6579e52e3f044dcb2.tar.gz
update to 0.3.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 35 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97c00556b8d2..b84143c38603 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-fastdtw
- pkgdesc = Python implementation of FastDTW, whis is an approximate Dynamic Time Warping (DTW) algorithm that provides optimal or near-optimal alignments with an O(N) time and memory complexity.
- pkgver = 0.3.2
+ pkgdesc = Python implementation of FastDTW
+ pkgver = 0.3.4
pkgrel = 1
url = https://github.com/slaypni/fastdtw
- arch = any
+ arch = x86_64
license = MIT
+ checkdepends = python-pytest-runner
makedepends = python-setuptools
- depends = python
- source = https://files.pythonhosted.org/packages/source/f/fastdtw/fastdtw-0.3.2.tar.gz
- md5sums = 63d55d14dbc4a40d2d1ceecb756d0ee4
+ makedepends = cython
+ depends = python-numpy
+ source = python-fastdtw-0.3.4.tar.gz::https://github.com/slaypni/fastdtw/archive/v0.3.4.tar.gz
+ sha256sums = da9bea6a9bc3c3a3424de1d82d3ce7d0545514ed255af16558ef4ddce28f36a7
pkgname = python-fastdtw
-
diff --git a/PKGBUILD b/PKGBUILD
index 69bfad09903f..9c7bc91865b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,34 @@
-# Maintainer: Conrad Sachweh <conrad+aur@spamthis.space>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Conrad Sachweh <conrad+aur@spamthis.space>
+
pkgname=python-fastdtw
-_pkgname=fastdtw
-pkgver=0.3.2
+_name="${pkgname#python-}"
+pkgver=0.3.4
pkgrel=1
-pkgdesc="Python implementation of FastDTW, whis is an approximate Dynamic Time Warping (DTW) algorithm that provides optimal or near-optimal alignments with an O(N) time and memory complexity."
+pkgdesc="Python implementation of FastDTW"
url="https://github.com/slaypni/fastdtw"
-arch=('any')
+arch=('x86_64')
license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('63d55d14dbc4a40d2d1ceecb756d0ee4')
+depends=('python-numpy')
+makedepends=('python-setuptools' 'cython')
+checkdepends=('python-pytest-runner')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('da9bea6a9bc3c3a3424de1d82d3ce7d0545514ed255af16558ef4ddce28f36a7')
-package() {
- cd $srcdir/${_pkgname}-${pkgver}
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
- python setup.py install --root="${pkgdir}/" --optimize=1
+check() {
+ cd "$_name-$pkgver"
+ local _ver="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-$_ver" python setup.py pytest
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -D LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -D README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
}