summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-24 13:51:15 -0500
committerCarlos Aznarán Laos2023-05-24 13:51:15 -0500
commite6215a8317c8df630382beaa92d4d9b534818df7 (patch)
tree1312464c626c6395664441f5d7df324aca156517
parent22c59a3bf480a50f9ddfb04085a3cb69b69e168b (diff)
downloadaur-e6215a8317c8df630382beaa92d4d9b534818df7.tar.gz
Bump version to 2.3.1
-rw-r--r--.SRCINFO18
-rw-r--r--CHANGELOG.md76
-rw-r--r--PKGBUILD53
-rwxr-xr-xget-changelog.sh3
4 files changed, 34 insertions, 116 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76fcc69ea7d..2f81ef4cb118 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
pkgbase = python-fastecdsa
- pkgdesc = Python library for fast elliptic curve crypto
- pkgver = 2.2.3
- pkgrel = 2
+ pkgdesc = Fast elliptic curve digital signatures
+ pkgver = 2.3.1
+ pkgrel = 1
url = https://github.com/antonkueltz/fastecdsa
- changelog = CHANGELOG.md
arch = x86_64
- license = Unlicense
+ license = custom
+ checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
- makedepends = python-sphinx
makedepends = python-wheel
depends = python
depends = gmp
- source = python-fastecdsa-2.2.3.tar.gz::https://files.pythonhosted.org/packages/source/f/fastecdsa/fastecdsa-2.2.3.tar.gz
- source = python-fastecdsa-2.2.3.tar.gz.asc::https://files.pythonhosted.org/packages/source/f/fastecdsa/fastecdsa-2.2.3.tar.gz.asc
- validpgpkeys = 67C1C1178894F9017D47AC0E15AB0E7C8A4019BF
- sha256sums = 269bdb0f618b38f8f6aec9d23d23db518046c3cee01a954fa6aa7322a1a7db8f
- sha256sums = SKIP
+ source = fastecdsa-2.3.1.tar.gz::https://github.com/antonkueltz/fastecdsa/archive/v2.3.1.tar.gz
+ sha512sums = 5dd11407ac3cd20fd686709857934c480a625774a9fdb67c5064daf975f0d82a4dd84fa3b8c12f95ec93bfba4577a836f0bfaf8e5f6899f2d7c62bb0acffca63
pkgname = python-fastecdsa
diff --git a/CHANGELOG.md b/CHANGELOG.md
deleted file mode 100644
index 82e532258abe..000000000000
--- a/CHANGELOG.md
+++ /dev/null
@@ -1,76 +0,0 @@
-# Changelog
-
-## [2.2.3]
-### Fixed
-- Minor doc issues and doc build
-
-## [2.2.2]
-### Added
-- Support for python3.10
-
-### Fixed
-- Error when adding two equal points where one point's coordinates are not reduced mod p (issue #75)
-
-## [2.2.1]
-### Fixed
-- Incorrect DER encoding of data with length >=0x80 (issue #61)
-
-## [2.2.0]
-### Added
-- Support for python3.9
-
-### Removed
-- Support for python3.5
-
-### Fixed
-- Multiplying by negative scalars (issue #70)
-- Reading and writing keys to disk using encoders that output bytes (PR #62)
-
-### Updated
-- `fastecdsa.keys.import_key` now has a consistent return type (`Tuple[Optional[int], Point]`) for public and private
-keys. Previously public key imports returned `Point`, they now return `Tuple[None, Point]`, in other words a tuple
-with the first entry being `None` (the private key) and the second entry being the point representing the public key.
-
-## [2.1.5]
-### Fixed
-- Timing leakage from nonce bit length aka the [Minerva](https://minerva.crocs.fi.muni.cz/) vulnerability (PR #60)
-
-## [2.1.4]
-### Fixed
-- Reduction by base point order in scalar multiplication breaks when input point does not have that order (PR #58)
-- Edge case for curves with order 2 was not handled (PR #58)
-- Signature verification of pre-hashed messages broken (PR #56)
-
-## [2.1.3]
-### Fixed
-- Multiplying base point by curve order caused an error (issue #54)
-
-## [2.1.2]
-### Fixed
-- Point at infinity handling in C extensions (issue #52)
-- DER signature decoding that assumed length was always encoded in one byte
-
-## [2.1.1]
-### Fixed
-- RFC6979 nonce generation for signatures on pre-hashed messages (issue #46)
-
-## [2.1.0]
-### Added
-- Curves W25519 and W448 from [NIST.SP.800-186](https://nvlpubs.nist.gov/nistpubs/SpecialPublications/NIST.SP.800-186-draft.pdf)
-
-### Fixed
-- Curves with no OID are not added to the lookup by OID map
-- Type validation for operations of points (issue #50)
-
-## [2.0.0]
-### Added
-- This changelog
-- Type hints for clearer function signatures
-
-### Removed
-- Support for python2.x
-- Support for python3.4 and older
-- Various unused imports
-
-### Fixed
-- Issue with benchmark script when C extensions weren't built in place (issue #44)
diff --git a/PKGBUILD b/PKGBUILD
index 52f31c462ccf..700b3425c82e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,41 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-pkgname=python-fastecdsa
-_pkg="${pkgname#python-}"
-pkgver=2.2.3
-pkgrel=2
-pkgdesc="Python library for fast elliptic curve crypto"
-arch=('x86_64')
-url="https://github.com/antonkueltz/fastecdsa"
-license=('Unlicense')
-depends=('python' 'gmp')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-sphinx' 'python-wheel')
-changelog=CHANGELOG.md
-source=(
- "$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz"
- "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz.asc")
-sha256sums=('269bdb0f618b38f8f6aec9d23d23db518046c3cee01a954fa6aa7322a1a7db8f'
- 'SKIP')
-validpgpkeys=('67C1C1178894F9017D47AC0E15AB0E7C8A4019BF')
+_base=fastecdsa
+pkgname=python-${_base}
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Fast elliptic curve digital signatures"
+arch=(x86_64)
+url="https://github.com/antonkueltz/${_base}"
+license=('custom')
+depends=(python gmp)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(python-pytest)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('5dd11407ac3cd20fd686709857934c480a625774a9fdb67c5064daf975f0d82a4dd84fa3b8c12f95ec93bfba4577a836f0bfaf8e5f6899f2d7c62bb0acffca63')
+# validpgpkeys=('67C1C1178894F9017D47AC0E15AB0E7C8A4019BF')
prepare() {
- cd "$_pkg-$pkgver"
- sed -i '/packages=/s/find_packages()/find_packages(exclude=["fastecdsa.tests*"])/' setup.py
+ cd ${_base}-${pkgver}
+ sed -i '/packages=/s/find_packages()/find_packages(exclude=["fastecdsa.tests*"])/' setup.py
}
build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
+ cd ${_base}-${pkgver}
+ python setup.py build_ext --inplace
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "$_pkg-$pkgver"
- python setup.py test
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest ${_base}/tests
}
package() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 README.rst -t "$pkgdir/usr/share/doc/$pkgname/"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
diff --git a/get-changelog.sh b/get-changelog.sh
deleted file mode 100755
index beb8915382b9..000000000000
--- a/get-changelog.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-curl -O https://raw.githubusercontent.com/antonkueltz/fastecdsa/v$1/CHANGELOG.md