summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2020-06-16 03:14:55 +0200
committerDavide Depau2020-06-16 03:14:55 +0200
commit26284ee41d179e586e1bdfe7304bae121e33411c (patch)
treef594e40a677ada258850f6080fd41b2a3fdf4fc1
downloadaur-26284ee41d179e586e1bdfe7304bae121e33411c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..135d12049fcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-fastecdsa-git
+ pkgdesc = Python library for fast elliptic curve crypto
+ pkgver = 2.1.2.r1.g4a16dae
+ pkgrel = 1
+ url = https://github.com/AntonKueltz/fastecdsa
+ arch = x86_64
+ license = custom:Unlicense
+ makedepends = python-setuptools
+ depends = python
+ depends = gmp
+ provides = python-fastecdsa
+ source = python-fastecdsa::git+https://github.com/AntonKueltz/fastecdsa.git
+ sha256sums = SKIP
+
+pkgname = python-fastecdsa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c629b39989ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Davide Depau <davide@depau.eu>
+
+_pkgname='python-fastecdsa'
+pkgname="${_pkgname}-git"
+pkgver=2.1.2.r1.g4a16dae
+pkgrel=1
+pkgdesc='Python library for fast elliptic curve crypto'
+arch=('x86_64') # Please let me know if it works on other archs
+url='https://github.com/AntonKueltz/fastecdsa'
+license=('custom:Unlicense')
+depends=('python' 'gmp')
+makedepends=('python-setuptools')
+provides=("$_pkgname")
+source=("$_pkgname::git+https://github.com/AntonKueltz/fastecdsa.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+