summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Winger2021-01-22 09:58:04 -0500
committerBenjamin Winger2021-01-22 09:58:04 -0500
commit05ab9e9a99e86990f13b192711dbb9a032f39d6e (patch)
tree0486cdee8d78934776d82abb09dcdb4470bbfe3c
downloadaur-05ab9e9a99e86990f13b192711dbb9a032f39d6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5904a2ae3306
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fasteners-git
+ pkgdesc = A python package that provides useful locks.
+ pkgver = 0.15.r34.g03e31bb
+ pkgrel = 1
+ url = https://github.com/harlowja/fasteners
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ provides = fasteners
+ conflicts = fasteners
+ source = fasteners::git+https://github.com/harlowja/fasteners
+ sha512sums = SKIP
+
+pkgname = fasteners-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be5c84c29c97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Benjamin Winger <bmw@disroot.org>
+
+pkgname=fasteners-git
+pkgver=0.15.r34.g03e31bb
+pkgrel=1
+pkgdesc="A python package that provides useful locks."
+provides=('fasteners')
+conflicts=('fasteners')
+arch=(any)
+url="https://github.com/harlowja/fasteners"
+license=(Apache)
+depends=("python")
+makedepends=("git" "python-setuptools")
+source=("fasteners::git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/fasteners"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/fasteners"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/fasteners"
+ python setup.py install --root $pkgdir
+}