summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2022-06-07 21:36:57 +0100
committerWill Handley2022-06-07 21:36:57 +0100
commitceb405ff5148b7cf441056cdbaff2e61feee53d1 (patch)
tree9f612289bde2bee41add24582a41bb08a68a664a
parent88ca0b5ad15d4e7e90cc282bf69726ff1390eff2 (diff)
downloadaur-ceb405ff5148b7cf441056cdbaff2e61feee53d1.tar.gz
Updated
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD21
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26b1914fdfa2..02a429a94932 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-fastkde
pkgdesc = Fast kernel density estimation
pkgver = 1.0.16
- pkgrel = 1
+ pkgrel = 3
url = https://bitbucket.org/lbl-cascade/fastkde
arch = any
makedepends = python-setuptools
@@ -10,8 +10,7 @@ pkgbase = python-fastkde
depends = python-scipy
depends = cython
options = !emptydirs
- source = https://bitbucket.org/lbl-cascade/fastkde/get/v1.0.16.tar.gz
- sha256sums = 3ed7043573766ce2e71b091541c9d41690c4758f95c12cf7bd4fabfb6a991050
+ source = https://files.pythonhosted.org/packages/source/f/fastkde/fastkde-1.0.16.tar.gz
+ sha256sums = 09ed51ae65848c4a8bc4cf607d4bb7371ac5140c0350601d0383f4f64e1ad375
pkgname = python-fastkde
-
diff --git a/.gitignore b/.gitignore
index b20752a93bec..a6b8c850ccb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.tar.xz
+*.tar.zst
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 03d05f11b2c2..d712f4c9fcd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=fastkde
-pkgname=python-$_modulename
+pkgname=python-fastkde
+_name=${pkgname#python-}
pkgver=1.0.16
-pkgrel=1
+pkgrel=3
pkgdesc="Fast kernel density estimation"
arch=(any)
url="https://bitbucket.org/lbl-cascade/fastkde"
@@ -16,10 +16,15 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/get/v${pkgver}.tar.gz")
-sha256sums=('3ed7043573766ce2e71b091541c9d41690c4758f95c12cf7bd4fabfb6a991050')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(09ed51ae65848c4a8bc4cf607d4bb7371ac5140c0350601d0383f4f64e1ad375)
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$(tar -tf v${pkgver}.tar.gz | head -n1)"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+