summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-08-06 13:25:53 -0400
committerGuillaume Horel2018-08-06 13:25:53 -0400
commite237923d13ab8afdddb1447853ef6cbaa9fbde37 (patch)
tree2bbfd07d6f3ae8393d6058fa9844d999e4cee505
parent01cd4379407f46acb0d7f33689fe916942e9617b (diff)
downloadaur-e237923d13ab8afdddb1447853ef6cbaa9fbde37.tar.gz
fix for python-zstandard-0.9
-rw-r--r--PKGBUILD20
-rw-r--r--zstandard-0.9.patch12
2 files changed, 27 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61214abed163..30e4f81ac61b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,9 @@ pkgver='0.1.5'
pkgrel=1
pkgdesc="A python implementation of the parquet format."
url="https://github.com/dask/fastparquet"
-checkdepends=('python-pytest')
+checkdepends=('python-pytest'
+ 'python-snappy'
+ 'python-lz4')
depends=('python' 'python-numba'
'python-numpy'
'python-thrift')
@@ -13,11 +15,19 @@ makedepends=('cython' 'python-setuptools')
optdepends=('python-snappy'
'python-lz4'
'python-lzo'
- 'python-brotli')
+ 'python-brotli'
+ 'python-zstandard')
license=('Apache')
-arch=('i686' 'x86_64')
-source=("https://github.com/dask/fastparquet/archive/$pkgver.tar.gz")
-sha256sums=('017c9812cc0180d10e134557a29296a56b40b32bb63c62f44a781e818792bf29')
+arch=('x86_64')
+source=("https://github.com/dask/fastparquet/archive/$pkgver.tar.gz"
+ "zstandard-0.9.patch")
+sha256sums=('017c9812cc0180d10e134557a29296a56b40b32bb63c62f44a781e818792bf29'
+ '08f34d49dc91c308a910347c6d141630eefb73d9e13284c0ace9893a9c834b39')
+
+prepare() {
+ cd "${srcdir}"
+ patch -p0 < ../zstandard-0.9.patch
+}
build() {
cd "${srcdir}/${_module}-${pkgver}"
diff --git a/zstandard-0.9.patch b/zstandard-0.9.patch
new file mode 100644
index 000000000000..af13f13889a7
--- /dev/null
+++ b/zstandard-0.9.patch
@@ -0,0 +1,12 @@
+diff -urN fastparquet-0.1.5-orig/fastparquet/compression.py fastparquet-0.1.5/fastparquet/compression.py
+--- fastparquet-0.1.5-orig/fastparquet/compression.py 2018-08-06 12:54:34.784680188 -0400
++++ fastparquet-0.1.5/fastparquet/compression.py 2018-08-06 13:00:39.692135158 -0400
+@@ -78,7 +78,7 @@
+ def zstd_compress(data, **kwargs):
+ kwargs['write_content_size'] = False
+ cctx = zstd.ZstdCompressor(**kwargs)
+- return cctx.compress(data, allow_empty=True)
++ return cctx.compress(data)
+ def zstd_decompress(data, uncompressed_size):
+ dctx = zstd.ZstdDecompressor()
+ return dctx.decompress(data, max_output_size=uncompressed_size)