summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-05-23 10:34:46 +0200
committerChristoph Fink2023-05-23 10:35:29 +0200
commita05545b58393cdd410283e971c7112851b22acec (patch)
tree84fee24c84beb1a04855d8e9271dc1885493dffe
parent388eabcf16ddd5b4b2ac354c694df81fbf0f85ff (diff)
downloadaur-python-fasttext-git.tar.gz
upgpkg: python-fasttext-git v0.9.2.r9.g0622aad-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
-rw-r--r--python-fasttext-git-cstdint.patch11
3 files changed, 33 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 003a0b4ca8b1..e3e18ca4d644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-fasttext-git
pkgdesc = Library for fast text representation and classification – Python bindings
- pkgver = v0.9.2.r8.g3697152
+ pkgver = v0.9.2.r9.g0622aad
pkgrel = 2
url = https://github.com/facebookresearch/fastText
arch = any
@@ -15,6 +15,8 @@ pkgbase = python-fasttext-git
provides = python-fasttext
conflicts = python-fasttext
source = python-fasttext-git::git+https://github.com/facebookresearch/fastText.git
- md5sums = SKIP
+ source = python-fasttext-git-cstdint.patch
+ b2sums = SKIP
+ b2sums = 5d7c95b54ceb1998b4fd62ce11b6ac94f5c5f95f46488b8da79b04e2b7275bde6af105b120ef61ce81d16418a822b105cc84007f2398e6eb1982b916ff689281
pkgname = python-fasttext-git
diff --git a/PKGBUILD b/PKGBUILD
index 2a345f85b8e8..c2d9ebdc2c90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ url="https://github.com/facebookresearch/fastText"
provides=("python-fasttext")
conflicts=("python-fasttext")
-pkgver=v0.9.2.r8.g3697152
+pkgver=v0.9.2.r9.g0622aad
pkgrel=2
arch=("any")
@@ -16,20 +16,32 @@ license=("BSD")
makedepends=("python-setuptools" "git")
depends=("pybind11" "python-future" "python-numpy" "python-scipy" "python-pytorch")
-source=("${pkgname}::git+https://github.com/facebookresearch/fastText.git")
-md5sums=("SKIP")
+source=(
+ "${pkgname}::git+https://github.com/facebookresearch/fastText.git"
+ "${pkgname}-cstdint.patch"
+)
+
+b2sums=(
+ "SKIP"
+ "5d7c95b54ceb1998b4fd62ce11b6ac94f5c5f95f46488b8da79b04e2b7275bde6af105b120ef61ce81d16418a822b105cc84007f2398e6eb1982b916ff689281"
+)
pkgver() {
- cd "${pkgname}"
+ cd "${srcdir}/${pkgname}"
git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g"
}
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch --forward --strip=1 --input "${srcdir}/${pkgname}-cstdint.patch"
+}
+
build() {
- cd "${srcdir}"/python-fasttext-git
+ cd "${srcdir}/${pkgname}"
python setup.py build
}
package() {
- cd "${srcdir}/python-fasttext-git"
+ cd "${srcdir}/${pkgname}"
python setup.py install --root=${pkgdir} --optimize=1
}
diff --git a/python-fasttext-git-cstdint.patch b/python-fasttext-git-cstdint.patch
new file mode 100644
index 000000000000..c6462e0b6032
--- /dev/null
+++ b/python-fasttext-git-cstdint.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text a/src/args.cc b/src/args.cc
+--- a/src/args.cc 2020-04-28 12:40:33.000000000 +0300
++++ b/src/args.cc 2023-05-16 11:48:14.001866135 +0300
+@@ -14,6 +14,7 @@
+ #include <stdexcept>
+ #include <string>
+ #include <unordered_map>
++#include <cstdint>
+
+ namespace fasttext {
+