summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2018-10-29 10:54:28 +0200
committerChristoph Fink2018-10-29 10:54:28 +0200
commitafd203676bfea4360ba7f801b8d4734b07c6f369 (patch)
tree5c96704dc0ca640e86c9eafb5bdbd9b8a103d9d2
downloadaur-afd203676bfea4360ba7f801b8d4734b07c6f369.tar.gz
python-fasttext-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97a064f1a3ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-fasttext-git
+ pkgdesc = Library for fast text representation and classification – Python bindings
+ pkgver = v0.1.0.r85.g25c3994
+ pkgrel = 1
+ url = https://github.com/facebookresearch/fastText
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = pybind11
+ depends = python-future
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-pytorch
+ provides = python-fasttext
+ conflicts = python-fasttext
+ source = python-fasttext-git::git+https://github.com/facebookresearch/fastText.git
+ md5sums = SKIP
+
+pkgname = python-fasttext-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa251b51f5da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgname='python-fasttext-git'
+pkgdesc="Library for fast text representation and classification – Python bindings"
+url="https://github.com/facebookresearch/fastText"
+
+provides=('python-fasttext')
+conflicts=('python-fasttext')
+
+pkgver=v0.1.0.r85.g25c3994
+pkgrel=1
+
+arch=('any')
+license=('BSD')
+
+makedepends=('python-setuptools' 'python2-setuptools')
+depends=('pybind11' 'python-future' 'python-numpy' 'python-scipy' 'python-pytorch')
+
+source=("${pkgname}::git+https://github.com/facebookresearch/fastText.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}"/python-fasttext-git
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/python-fasttext-git"
+ python setup.py install --root=${pkgdir} --optimize=1
+}