summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-01-13 14:34:06 -0500
committerGuillaume Horel2017-01-13 14:42:49 -0500
commit004eba035fd7c4d2644a9b2a2e50a37a0e377a5b (patch)
tree2ec043da82ad805307a966eea843835b6dbb9a3f
downloadaur-004eba035fd7c4d2644a9b2a2e50a37a0e377a5b.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e190d345731
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-feather
+ pkgdesc = Fast, interoperable binary data frame storage for Python, R
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/wesm/feather
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = cython
+ depends = python
+ depends = python-pandas>=0.17.1
+ source = https://github.com/wesm/feather/archive/v0.3.1.tar.gz
+ md5sums = 3700893e1f21bc850c9e80446d82c185
+
+pkgname = python-feather
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a25fe5c570e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgbase=('python-feather')
+pkgname=('python-feather')
+_module='feather'
+pkgver='0.3.1'
+pkgrel=1
+pkgdesc="Fast, interoperable binary data frame storage for Python, R"
+url="https://github.com/wesm/feather"
+depends=('python'
+ 'python-pandas>=0.17.1')
+makedepends=('python-setuptools'
+ 'cython')
+license=('Apache')
+arch=('i686' 'x86_64')
+source=("https://github.com/wesm/feather/archive/v$pkgver.tar.gz")
+md5sums=('3700893e1f21bc850c9e80446d82c185')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}/python"
+ ln -s ../cpp/src src
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}/python"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}